Test and Measurement Forum

CAN decode beta 6.7.11.1

Forum for discussing PicoScope version 6 (non-automotive version)

CAN decode beta 6.7.11.1

Postby bennog » Tue Jan 01, 2013 6:09 pm

For some reason the CAN decoder statistics starts decoding at 524 kbaud while initial setup tells 500 kbaud.
It seems this only happens when using streaming mode.
When checked with the rulers the bits are exactly 2 us and not 1.9 as 424 kboud would be.
Because of this the analyser thinks there are errors while there are no errors.

http://www.ans-net.nl/picotech/can%20decode%20baud.png
Sorry needs to be url (image is 1200 pix wide)

Also in statistics the number of stuffed bits is always 0 (after some scrolling)

Both types of error can be seen in above image.

The psdata file is over here (33 MB) http://www.ans-net.nl/picotech/20130101-0001.psdata
bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am

Re: CAN decode beta 6.7.11.1

Postby Martyn » Thu Jan 03, 2013 7:52 am

I have opened up your data file and do not see the data you have posted in the image. Can you repost an image with the complete Picoscope screen, not just the serial decoding table, and including the vertical rulers showing the 2us as well.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2344
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: CAN decode beta 6.7.11.1

Postby bennog » Thu Jan 03, 2013 10:44 am

bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am

Re: CAN decode beta 6.7.11.1

Postby Martyn » Thu Jan 03, 2013 11:31 am

Rechecked and it was working with the 6.7.10 Beta I had installed, but does fail as described with 6.7.11, so I have flagged this for investigation.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2344
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: CAN decode beta 6.7.11.1

Postby Martyn » Thu Jan 03, 2013 12:24 pm

If you change the decode threshold to 1.2V it works.

The developers are working on this section of code and have mentioned that this is a Beta so is not bug free.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2344
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: CAN decode beta 6.7.11.1

Postby bennog » Thu Jan 03, 2013 1:11 pm

I know this is a beta version, i am trying to help the developers.
And using the Picoscope primarily for CAN bus problem solving.

If I set the threshold to 1.2V I notice the following problems. (the same as 1.15V)
- number of stuffed bits (always 0)
- Statistics baud rate 524 kbaud
- error frames at other places (frame 642)

I don’t know if the 524 kbaud is the result of the data decoding of the source for the decoding.
If it is the source then the errors will disappear when the baud rate is calculated correctly.
bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests