Test and Measurement Forum

debug CAN protocol

Forum for discussing PicoScope version 6 (non-automotive version)

debug CAN protocol

Postby drnicolas » Tue Dec 25, 2012 3:39 pm

I am a newbie with a 2205 MSO.

I try to debug a CAN-bus.
I have absolutely no idea what I really need to connect.
WIth the first try, I connected a probe on Chan A to CAN High and the clamp to GND. Okay ?
The probe A then is configured to DC and Auto - correct ?

In the serial decoding window then i find a line marked "A" and a drop-down box which can be set to "CAN High".
Now for the real problem:
pressing the small "flash"-sign button, I get a error message in german: "bitte wählen sie die entsprechende Anzahl von Sonden, Auto. Erkennung fehlgeschlagen". I would translate "Sonden" with "probes" !?
Some where in this forum I found a screenshot with a message "please choose appropriate number of samples. Discovery failed"

Can someone give me a good tutorial how to do serial decoding - especially for CAN protocol ?
drnicolas
Newbie
 
Posts: 0
Joined: Tue Dec 25, 2012 3:08 pm

Re: debug CAN protocol

Postby bennog » Tue Dec 25, 2012 8:54 pm

Best results you get when you use a differential probe on Can-H and Can-L
If you dont have this you plug ch-A on Can-H and can shield, ch-B on Can-L and shield.
Then add a math chanal A-B and do serial decoding on the math chanal.

You need a sample rate at least 5 times the CAN-bus speed. But 10 times is better.

O and use the latest beta version of the software.

Regards,
Benno
bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am

Re: debug CAN protocol

Postby drnicolas » Sat Jan 19, 2013 1:29 pm

Thank you for your help.
In the meantime it works.
drnicolas
Newbie
 
Posts: 0
Joined: Tue Dec 25, 2012 3:08 pm


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests