Test and Measurement Forum

Bug fix for interval trigger and/or persistent mode?

Forum for discussing PicoScope version 6 (non-automotive version)

Bug fix for interval trigger and/or persistent mode?

Postby tommyjunge » Thu Dec 20, 2012 6:03 am

Hi,

a while ago, I have reported a bug in the interval trigger and in persistent mode, see http://www.picotech.com/support/topic11605.html, which has been confirmed.

When will there be a fix for at least one of the two problems?

Regards,
Tom
tommyjunge
User
User
 
Posts: 2
Joined: Thu May 14, 2009 9:38 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby bennog » Sun Dec 23, 2012 3:23 pm

I second this, the interval of beta releses can be higher as bugs are resolved.
bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby alan » Sun Dec 23, 2012 9:40 pm

Hi,

A new beta release R6.7.11 was uploaded on the 21st Dec - http://labs.picotech.com/

It has quite a few bug fixes but unfortunately I dont know if your issue is sorted or not as the office is now closed for Christmas.

Regards
Alan
alan
Site Admin
Site Admin
 
Posts: 171
Joined: Thu May 25, 2006 8:02 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby bennog » Tue Dec 25, 2012 4:03 pm

alan wrote:Hi,
A new beta release R6.7.11 was uploaded on the 21st Dec - http://labs.picotech.com/
Regards
Alan


uuuuuuh, Alan,

I think you should fix the page (release 21, Dec 2009) :D

Regards,
Benno
bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby alan » Tue Dec 25, 2012 10:35 pm

bennog wrote:
uuuuuuh, Alan,

I think you should fix the page (release 21, Dec 2009) :D

Regards,
Benno


Thats odd - it shows as 2012 in Chrome and IE on my PC (set to UK English).
alan
Site Admin
Site Admin
 
Posts: 171
Joined: Thu May 25, 2006 8:02 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby bennog » Wed Dec 26, 2012 8:25 am

Date is now correct (strange it showed 2009)

Never mind.

Benno
bennog
Guru
Guru
 
Posts: 79
Joined: Mon Nov 26, 2012 9:16 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby Martyn » Thu Dec 27, 2012 8:59 am

It might have been a cache issue.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Bug fix for interval trigger and/or persistent mode?

Postby tommyjunge » Sun Dec 30, 2012 8:13 am

A new beta release R6.7.11 was uploaded on the 21st Dec


The new beta release fixes the persistent mode problem sort of. Persistent mode now works for all sweeping speeds, but I have seen several program freezes. A report has been automatically sent to Picotech.

Unfortunately, the events I want to capture are too rare to see them in persistent mode, so I need the interval trigger.

The interval trigger has not been fixed yet by the new beta version. What is the plan on this one?

Tom
tommyjunge
User
User
 
Posts: 2
Joined: Thu May 14, 2009 9:38 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby Martyn » Wed Jan 02, 2013 12:43 pm

The team are currently working on this issue, I will provide an update shortly.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Bug fix for interval trigger and/or persistent mode?

Postby tommyjunge » Tue Jan 22, 2013 11:29 am

Hi,

is there any progress on fixing the interval trigger?

Best regards,
Tom
tommyjunge
User
User
 
Posts: 2
Joined: Thu May 14, 2009 9:38 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby Martyn » Thu Jan 31, 2013 7:48 am

Please try the attached PS5000.dll driver file
Attachments
PS5000.zip
Interval Trigger Fix
(379.37 KiB) Downloaded 89 times
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Bug fix for interval trigger and/or persistent mode?

Postby tommyjunge » Sat Feb 09, 2013 8:11 pm

Hi Martyn,

thank you very much for the patched dll. It was quite a job to replace the system protected original, but it is working great now. Intervall trigger works as it is supposed to with this new dll.
This dll isn't supposed to fix the persistent mode issue though, right?

Best regards,
Tom
tommyjunge
User
User
 
Posts: 2
Joined: Thu May 14, 2009 9:38 am

Re: Bug fix for interval trigger and/or persistent mode?

Postby Martyn » Mon Feb 11, 2013 7:39 am

From what I understood the persistent mode issue was with the PicoScope software and should have been resolved in the latest Beta version. This dll was intended to fix the outstanding trigger issue.

if you are still having issues then please cut and paste the Help->About text, which details the all the version information, together with a description of the outstanding issue and we will look into it.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests