Test and Measurement Forum

Using Capture on Trigger alarm slows down trigger re-arm

Forum for discussing PicoScope version 6 (non-automotive version)

Using Capture on Trigger alarm slows down trigger re-arm

Postby MikeSparks » Mon Dec 03, 2012 11:57 am

Hi,
I am using a Picosope 3206A with beta version software 6.7.2.1 to capture a series of transient pulses. I'm running Picoscope 6 on a Windows 7 laptop. Running in normal mode, the scope can correctly capture 3 events in a period of 1.3 seconds. However, when I use the "alarm capture on trigger" feature to store each captured waveform to hard disk, only 2 events are captured. It looks to me like after the first trigger, while the waveform is being saved to disk the second event occurs but the trigger has not yet been re-armed so it is not captured. It seems it takes around 700ms until the trigger is re-armed. It is only after the file is saved and the trigger is re-armed that the third event triggers another capture.
Can you confirm, am I correct in thinking that the trigger is not re-armed until after the write to disk is complete?
Any suggestions for how to minimise the re-arm time to make sure I can capture as many events as possible?

Regards
Mike
MikeSparks
Newbie
 
Posts: 0
Joined: Tue Nov 20, 2012 1:14 pm

Re: Using Capture on Trigger alarm slows down trigger re-arm

Postby Martyn » Mon Dec 03, 2012 2:08 pm

How many captures are you looking for in total, and how many samples in each capture ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2287
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests