Ethernet connection not working on PicoLog CM3

Post any questions you may have about our current range of USB data loggers
Post Reply
SandyMessini
Newbie
Posts: 0
Joined: Mon Nov 19, 2012 12:40 am

Ethernet connection not working on PicoLog CM3

Post by SandyMessini » Mon Nov 19, 2012 12:50 am

I have tried to use the ethernet connection on the PicoLog CM3, but it doesn't appear to be working.

I've installed the software, and connected via the USB.

However, when I plug in the ethernet cable, there are no lights (either in the CM3 nor the PC), and the PC tells me there is nothing connected.

We have bought 20 of these, so we want the ethernet to be working.

Martyn
Site Admin
Site Admin
Posts: 3371
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Ethernet connection not working on PicoLog CM3

Post by Martyn » Mon Nov 19, 2012 8:45 am

Have you run the EthernetSettings program to set up the IP address of the CM3 ?

You will find it in the SDK or installed here "C:\Program Files\Pico Technology\Pico Full"
Martyn
Technical Support Manager

SandyMessini
Newbie
Posts: 0
Joined: Mon Nov 19, 2012 12:40 am

Re: Ethernet connection not working on PicoLog CM3

Post by SandyMessini » Tue Nov 20, 2012 12:09 am

Ok, I've found that. It is not mentioned in the manual.

I am able to use EthernetSettings to set the IP address, listening port and set to "Enabled". (how do you disable it again??)

However, when I go to PLW Recorder, and "settings", then select CM3(ethernet), there is no device to select. (unlike when I select CM3(USB), where I can select a device)
Even if I put in the IP address and listening port down the bottom and hit refresh, there is still no device to select.



Also, how do I enable Power over IP?

Thanks for your help.

Martyn
Site Admin
Site Admin
Posts: 3371
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Ethernet connection not working on PicoLog CM3

Post by Martyn » Tue Nov 20, 2012 7:39 am

Disable it by setting the IP address to 0, although there is no issue with leaving it in and just unplugging the device.

What IP address and port have you selected ?
Can you ping the CM3 from a command prompt window on your computer ?
Do you have a firewall enabled on your PC blocking the telnet requests ?
Is the CM3 on the same subnet as your PC ?

The device will automatically detect powe over ethernet if the switch it is connected to provides this, no configuration needed.
Martyn
Technical Support Manager

SandyMessini
Newbie
Posts: 0
Joined: Mon Nov 19, 2012 12:40 am

Re: Ethernet connection not working on PicoLog CM3

Post by SandyMessini » Mon Nov 26, 2012 7:24 am

Ok, everything seems to be working!! Thank you very much!

One other question:

What is the maximum power consumption of the PicoLog CM3?

Thanks for your help.

Martyn
Site Admin
Site Admin
Posts: 3371
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Ethernet connection not working on PicoLog CM3

Post by Martyn » Mon Nov 26, 2012 8:18 am

It will be less than 2W with both USB and Ethernet plugged in although I don't have exact figures.
Martyn
Technical Support Manager

Post Reply