Test and Measurement Forum

Unable to open picoscope in labview example

Post your LabVIEW discussions here

Unable to open picoscope in labview example

Postby egwis » Sun Nov 11, 2012 10:17 pm

Hi,

I just got a picoscope 2208. I installed picoscope 6 from the provided CD and everything worked fine.

However, I'm unable to run the provided labview example (ps2000_fast_stream.vi). When I run the vi, the pop-up window with the picoscope logo appears and after the green bar loads about 10%, I get an "unable the open the picoscope" error message.

I'm running win 7 64 bit, but a 32 bit labview 8.5.

Thanks
egwis
Newbie
 
Posts: 0
Joined: Wed Oct 17, 2012 7:41 pm

Re: Unable to open picoscope in labview example

Postby Martyn » Mon Nov 12, 2012 11:08 am

The 2208 is one of the newer 2000 series units and requires the "a" version of the sdk, (including example vi's for block, rapidblock, and streaming), the file you mention is from the older one

Please go to http://www.picotech.com/software.html and select PicoScope 2208 at Step 1 and the SDK at Step 2
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Unable to open picoscope in labview example

Postby egwis » Mon Nov 12, 2012 7:28 pm

Thanks Martyn!

I downloaded the "a" version of the sdk. Unfortunately, two of the sub-vi are in a newer version of Labview: picostatus.vi and picoErrorHandler.vi. Is there a labview 8.5 compatible version of these files somewhere?
egwis
Newbie
 
Posts: 0
Joined: Wed Oct 17, 2012 7:41 pm

Re: Unable to open picoscope in labview example

Postby Hitesh » Tue Nov 13, 2012 1:42 pm

Hi,

Please find attached a zip file containing the two vi files saved for LabVIEW 8.5

Hope this helps.
Attachments
PS2000a_Files_for_LabVIEW_8_5.zip
Contains picoStatus.vi and picoErrorHandler.vi for LabVIEW 8.5
(18.25 KiB) Downloaded 150 times
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Unable to open picoscope in labview example

Postby egwis » Tue Nov 13, 2012 6:47 pm

Yes, it works now. Thanks Martyn & Hitesh!
egwis
Newbie
 
Posts: 0
Joined: Wed Oct 17, 2012 7:41 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 2 guests