Test and Measurement Forum

PicoScope Drivers for Labview?

Post your LabVIEW discussions here

PicoScope Drivers for Labview?

Postby MikeSD » Fri Jul 27, 2012 9:13 am

I'm wondering about the "drivers" for Labview. I have used LabView before and before I could connect to an instrument, I had to "install" instrument drivers for the instrument to be used. But with the PicoScope, when I download the "drivers and examples" there doesn't seem to be any drivers or installation required.

When I use MAX and serarch for instruments, it says none connected. However, the examples work ok.

So my questions are:

1) Are there actually "device drivers" required for PicoScope, for use with Labview?
2) If there are, why isn't there a specific "install" operation?
3) Why doesn't MAX find the instrument, if it's working ok on the examples?

Can someone explain this "driver" issue, with regards to using PicoScope with LabView?

Thanks,
MikeSD
Newbie
 
Posts: 0
Joined: Tue Jul 24, 2012 9:28 pm

Re: PicoScope Drivers for Labview?

Postby Martyn » Fri Jul 27, 2012 12:50 pm

To access one of our scopes from LabView you do need a driver file. This file will be the generic Windows driver used by our own software and other example code, for example ps3000a.dll for the new 3000 series scopes.

It is accessed through function call blocks in Labview directly within the vi's. Open any of the example and look for the OpenUnit block, or any other of the driver API function blocks, take a closer look and you should see how it is done.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests