Test and Measurement Forum

PS3205: Issue with driver under Win7 x64

Post any questions you may have about our current range of oscilloscopes

PS3205: Issue with driver under Win7 x64

Postby B&O_sts » Mon Jun 11, 2012 10:03 am

Hi guys.

I saw that there are a few issues with x64 driver on Windows 7, but nothing matches exactly the problem that I experience.
I use a PicoScope 3205 and it always worked flawlessly under Win XP (32-bit). But as I changed to Win7 x64 lately I experienced that the driver sometimes "crashes" when I run PicoScope software.

Just now I experienced that the PicoScope works in 5 minutes and then it suddenly loses connection and Windows says that the "USB device is not recognized". Taking the the USB cable out and putting it in again sometimes works, but it takes several tries. I experienced the same issue also with a 3205A also on an entirely different PC (also running Win x64).

Are there any known issues? Or can you help me otherwise?

Thanks!
-- Stefan Schwarz
B&O Global Service
B&O_sts
Newbie
 
Posts: 0
Joined: Wed Apr 18, 2012 7:32 pm

Re: PS3205: Issue with driver under Win7 x64

Postby TinWhisker » Wed Jun 13, 2012 8:37 am

What version of PicoScope are you using?

I've had this with a bad USB lead and with a beta (albeit months ago) of PicoScope (independant issues).
So I suggest another lead and/or an older version of PicoScope.


(B&O; still see it about, though mainly when I get given stacks of 80's era decks, amps and tuners :lol:)
TinWhisker
Newbie
 
Posts: 0
Joined: Fri Dec 16, 2011 10:48 am

Re: PS3205: Issue with driver under Win7 x64

Postby Martyn » Wed Jun 13, 2012 8:55 am

The other point is to ensure that you are plugged into the rear USB connectors and not the front ones as these have flying leads to the motherboard.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PS3205: Issue with driver under Win7 x64

Postby B&O_sts » Mon Jun 18, 2012 1:19 pm

Hi you both.

Sorry, for the late reply. I am using the latest PicoScope version (always).
There is only one USB Connector on my PicoScope and the problem has never occured under Windows XP (32 bit).

The problems occured first after I switched to Win7 (64 bit) lately. And the same happens on another computer with Windows 7 64 bit. I can't try it on Windows 7 (32 bit) so it can be a general Win7 issue (or my PicoScope is ill, but as soon as I switch to WinXP again, it works without problems).

Thanks for your help,
-- Stefan
B&O_sts
Newbie
 
Posts: 0
Joined: Wed Apr 18, 2012 7:32 pm

Re: PS3205: Issue with driver under Win7 x64

Postby Martyn » Tue Jun 19, 2012 6:00 am

Which USB port are you connecting to on the PC end ?

And how much memory do you have on your PC ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2350
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests