Test and Measurement Forum

2 applications using adc11

Post general discussions on using our drivers to write your own software here

2 applications using adc11

Postby MatIng » Mon Oct 04, 2004 7:37 am

Hi,

We develop a soft in Vee using adc11.
We can have 4 instruments on the same desktop, with the soft run 4 times each using a different channel.
For the first instrument, we use the channel 1, we initialize the adc11 and it works very well.
But when we use the second, on channel 2, we have invalid values on both instruments, like interferences.
I think, the problem is that we initialize adc11 two times (with adc11_open_unit ; adc11_get_unit_info ; adc11_set_do ) one time for the channel 1, and after for the 2.
If I check the signal with picoscope, the 2 channels get the good signal.

How could I solve my problem ?

thanks

Franck.
MatIng
Newbie
 
Posts: 1
Joined: Mon Oct 04, 2004 6:59 am

Postby markspencer » Fri Oct 22, 2004 8:12 am

Hi,

I am sorry to hear that you are experiencing problems. When opening the ADC-11 with the open unit you only need call the ADC11_open_unit function once. By calling it more than once you are trying to make different programs perform different takes at the same time.

Therefore, only one piece of software can invoke the ADC-11 at a time. However, you can create one piece of software that can use all 11 channels at the same time in a similar manner as Picoscope or Picolog. I would advise that you look at the examples provide especially the C example.

Best regards,
Regards,

Mark Spencer
User avatar
markspencer
Site Admin
Site Admin
 
Posts: 598
Joined: Wed May 07, 2003 9:45 am


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests