Test and Measurement Forum

Picopp folder missing in SDK r10.4.1.1

Post general discussions on using our drivers to write your own software here

Picopp folder missing in SDK r10.4.1.1

Postby BSI » Mon Jun 04, 2012 5:14 pm

I want to install the Pico driver without installing Picoscope.

In the SDK 10.4.1.1 folder ..system\, the SystemDrivers readme file indicates:
Before using the examples for USB devices, kernel
drivers must be installed. This is normally performed
by the PicoScope or PicoLog installer.

In order to install kernel drivers manually run dpinst.exe
which can be found in one of the subfolders.

For x86 you will also need to copy picopp.inf to SYSTEMROOT\inf
and picopp.sys to SYSTEMROOT\system32\drivers.


Running DPinst.exe seems to have no effect. There is also no trace of picopp.inf and picopp.sys in this SDK version: no picopp folder anywhere. I worked before with SDK 10.1.0.17 and it had a picopp folder...

thx.
L
BSI
Newbie
 
Posts: 0
Joined: Wed May 12, 2010 3:15 pm
Location: Canada

Re: Picopp folder missing in SDK r10.4.1.1

Postby TinWhisker » Wed Jun 06, 2012 7:58 am

Edit: I stand corrected :D
Last edited by TinWhisker on Thu Jun 07, 2012 8:06 am, edited 1 time in total.
TinWhisker
Newbie
 
Posts: 0
Joined: Fri Dec 16, 2011 10:48 am

Re: Picopp folder missing in SDK r10.4.1.1

Postby Martyn » Wed Jun 06, 2012 12:36 pm

You will find them in system\x86 and they are needed. If you use Picolog or Picoscope6 they will already be installed.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Picopp folder missing in SDK r10.4.1.1

Postby BSI » Sat Jun 09, 2012 3:15 pm

Martyn,
Here is the content of the system\x86 folder from the SDK zip file:
System-x86 folder.PNG


no picopp.sys nor .inf, so they can't be manually placed in their expected location...

L.
BSI
Newbie
 
Posts: 0
Joined: Wed May 12, 2010 3:15 pm
Location: Canada

Re: Picopp folder missing in SDK r10.4.1.1

Postby Martyn » Mon Jun 11, 2012 7:52 am

Sorry for that, it is actually missing from that release.

I have attached the x86 folder here.
Attachments
x86.zip
(4.07 MiB) Downloaded 160 times
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Picopp folder missing in SDK r10.4.1.1

Postby BSI » Fri Jun 15, 2012 3:53 pm

Ha !! :mrgreen: ,
I was not crazy after all.
Thx
Laurent
BSI
Newbie
 
Posts: 0
Joined: Wed May 12, 2010 3:15 pm
Location: Canada


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests