Test and Measurement Forum

Virtual Machines and PicoScope

Post your Linux discussions here

Virtual Machines and PicoScope

Postby robin48gx » Wed May 30, 2012 10:42 am

I bought a picoscope for work and initially tried to use it with Linux, but apparently there is not supported Linux gui for the product. DOH! I would not have bought this if I had known this.

However I soldiered on and tried to use a winxp virtual machine. This connected and worked for very short
periods of time and then the GUI hung up.
I tried a win7 virtual machine and after enabling USB2 on it, the GUI would start up and then
hang with the message "enumerating devices"....


Other than a straight boot of windows, which I not not want, too many development tools rely on linux
here, how do you get this thing to work ?
robin48gx
Newbie
 
Posts: 0
Joined: Tue May 29, 2012 7:57 am

Re: Virtual Machines and PicoScope

Postby TinWhisker » Fri Jun 01, 2012 11:47 am

Which scope do you have?

There are Linux drivers available (and to come), as well as some community efforts - I'm sure there's enough to get you on your feet.

Others use VM's ok, have a search here to see how/what version.
TinWhisker
Newbie
 
Posts: 0
Joined: Fri Dec 16, 2011 10:48 am

Re: Virtual Machines and PicoScope

Postby PRJeanneret » Sat Jun 16, 2012 10:22 am

If it's any help I too have had problems getting my picoscope (3206B) running in a VM. The picoscope software seems to have problems in VirtualBox but does work reasonably well in VMPlayer. It's a bit of a shame that we have to run a VM purely for the 'scope.

Paul
PRJeanneret
Newbie
 
Posts: 0
Joined: Wed Jan 18, 2012 4:35 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 0 guests