Rise time measurements

Post any questions you may have about our current range of oscilloscopes
Post Reply
User avatar
jane
Newbie
Posts: 0
Joined: Sat Mar 03, 2012 12:20 pm
Location: Norway

Rise time measurements

Post by jane » Sat Mar 24, 2012 5:03 pm

I'm doing rise time measurements using an external generator. Square wave is 2kHz, 10Vpp.

80/20% measurement tells me 400ns but 90/10% says 153us (!)
Adding cursors to the graph indicates 680ns for the 90/10%.

Why is the 90/10% measurement so far out?

PicoScope® 6 - PC Oscilloscope software version: 6.6.18.8
Model: PicoScope 4262
Driver Version: 1.1.0.211
Firmware Version: 1.0.5.0 / 1.0.11.0

RTime.gif

Martyn
Site Admin
Site Admin
Posts: 3226
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Rise time measurements

Post by Martyn » Tue Mar 27, 2012 12:57 pm

We are currently looking at the Picoscope 6 measurements as there may be a few inaccuracies with these.
Martyn
Technical Support Manager

chelaghma
Newbie
Posts: 0
Joined: Wed May 30, 2012 6:39 pm

Re: Rise time measurements

Post by chelaghma » Fri Jun 01, 2012 10:35 am

I am seeing the same issue, is there any updates on this issue ?

ziko
Advanced User
Advanced User
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: Rise time measurements

Post by ziko » Fri Jun 08, 2012 3:52 pm

HI I have investigated this myself and there is a problem with the 10- 90% calculations for rise and fall time. The software engineers are aware of it and we will be looking at fixing this.

Kind regards
Ziko

Technical Specialist

Post Reply