Test and Measurement Forum

Humidiprobe not open error

Post your LabVIEW discussions here

Humidiprobe not open error

Postby briancr » Mon Feb 06, 2012 11:08 am

I am trying to run the example humidiprobe vi supplied by you on Labview 2011. The vi runs ok the first time that you open it for a PC restart. If i then stop the vi and try to restart it will no longer run and returns Humidiprobe not open error. Can anyone help please.
briancr
Newbie
 
Posts: 0
Joined: Mon Feb 06, 2012 10:58 am

Re: Humidiprobe not open error

Postby Martyn » Mon Feb 06, 2012 1:01 pm

As discussed on the phone before stopping the vi you will need to flick the toggle switch to Off to close the unit and release the handle. You will find the CloseUnit dll function call in the stacked sequence.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Humidiprobe not open error

Postby briancr » Mon Feb 06, 2012 9:17 pm

Ok thankyou.
briancr
Newbie
 
Posts: 0
Joined: Mon Feb 06, 2012 10:58 am

Re: Humidiprobe not open error

Postby briancr » Mon Sep 17, 2012 9:43 pm

Is it possible for me to open the humidiprobe read one value and then close humidiprobe so i can use in a subvi. I have tried just linking open, get single value and close and it doesnt appear to work.
briancr
Newbie
 
Posts: 0
Joined: Mon Feb 06, 2012 10:58 am

Re: Humidiprobe not open error

Postby briancr » Tue Sep 18, 2012 9:22 am

I have now created a state machine for the humidiprobe. It works ok when i use highlight execution but if i run normally i get no data out
briancr
Newbie
 
Posts: 0
Joined: Mon Feb 06, 2012 10:58 am

Humidiprobe functions

Postby briancr » Tue Sep 18, 2012 10:18 am

Can you tell me what functions Humididprobeapplyfix and humidiprobeAcknowledge are for.
Thankyou
briancr
Newbie
 
Posts: 0
Joined: Mon Feb 06, 2012 10:58 am

Re: Humidiprobe not open error

Postby Martyn » Tue Sep 18, 2012 10:35 am

Those are internal functions and not for general use.

Please can you post your vi and we can take a look for you.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Humidiprobe not open error

Postby briancr » Tue Sep 18, 2012 11:06 am

Hi
i have attached VI this one works but with quite big delays set in each state. Error handling not complete yet
Attachments
Hprobe state machine.vi
(20.39 KiB) Downloaded 169 times
briancr
Newbie
 
Posts: 0
Joined: Mon Feb 06, 2012 10:58 am

Re: Humidiprobe not open error

Postby Martyn » Mon Sep 24, 2012 9:07 am

New readings are available every two seconds, so make sure you have these delays built into your vi
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests