Test and Measurement Forum

Pico 6 cannot detect Picoscope 2000

Having problems ? let us know the details here

Pico 6 cannot detect Picoscope 2000

Postby garyl » Tue Jan 31, 2012 8:29 pm

On a WinXP machine, I installed the software (updating from the web) successfully, then plugged in the P2000. It said installing drivers, and then hung there. I waited an hour, but with nothing happening, tried to restart, and it hung - had to remove the power cord.

Now, when I plug in the P2000, it shows up in the USB list, but the scope software says it's not there.

I can't uninstall the driver (machine just hangs), and cannot re-install because Windows says that I already have the most appropriate driver installed.

What do I do now?
garyl
Newbie
 
Posts: 0
Joined: Tue Jan 31, 2012 8:24 pm

Re: Pico 6 cannot detect Picoscope 2000

Postby Hitesh » Wed Feb 01, 2012 4:14 pm

Hi Garyl,

Which version of PicoScope did you download?

Try unplugging the device from the PC, then either by starting the PicoScope installer or via the Add/Remove Programs feature in the Control Panel, choose the option to repair the installation and then plug the device back in.

It's possible the driver became corrupted on install. When you tried to uninstall the device, are you referring to the uninstall option in the Device Manager?

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Pico 6 cannot detect Picoscope 2000

Postby garyl » Thu Feb 02, 2012 5:02 pm

The version is 6.6.16.12.

I've already tried the option to repair the installation - it says completed successfully.

Turned the machine off and on again, plugged in the PicoScope. Fired up PicoScope6 and same thing - no suitable device found.

I installed the same downloaded file on another machine, and no problem there.
garyl
Newbie
 
Posts: 0
Joined: Tue Jan 31, 2012 8:24 pm

Re: Pico 6 cannot detect Picoscope 2000

Postby Hitesh » Fri Feb 03, 2012 5:14 pm

Is the device working on another PC then?

With the device plugged in to the PC where it is not working, please right-click the PicoScope 2000 Series entry and select the option to uninstall.

Next, uninstall the PicoScope software and navigate to the following folder:

C:\Users\<Your user name>\AppData\Local\

To access the AppData folder and below you will need to be able to view hidden folders within Windows:

  • Go to C:\Users\<User Name> in Windows Explorer
  • Click Tools -> Folder options
  • Click the View tab, then under Hidden Files and Folders, select the tickbox to 'Show hidden files and folders', then click 'OK'.

Delete the Pico Technology folder, then reboot the PC and re-install the PicoScope software. Once this is complete, connect the PicoScope to the PC.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Pico 6 cannot detect Picoscope 2000

Postby ItronLb » Mon Feb 13, 2012 8:51 am

Hi,
I reply to this post because I think I have a similar problem.
I have a Picoscope3424 device and windows XP correctly detect it.
When I launch install and launch software PicoFull_r5_16_2.exe, it's work fine.

But with software 6.6.16.12 I got the windows "No Device Found" at the application start. Could you help me?

Regards,
ItronLb
Newbie
 
Posts: 0
Joined: Mon Feb 13, 2012 8:38 am

Re: Pico 6 cannot detect Picoscope 2000

Postby Hitesh » Mon Feb 13, 2012 12:42 pm

Hi there,

This is being investigated as other Customers have contacted us regarding their devices. The common theme seems to be Windows XP. It would be helpful if you could let us know whether it is 32-bit or 64-bit, and whether the PC is a desktop or laptop.

Thanks,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Pico 6 cannot detect Picoscope 2000

Postby ItronLb » Wed Feb 15, 2012 8:07 am

Hi,
My Pc is a desktop with XP 32-bits.
ItronLb
Newbie
 
Posts: 0
Joined: Mon Feb 13, 2012 8:38 am

Re: Pico 6 cannot detect Picoscope 2000

Postby Martyn » Wed Feb 22, 2012 12:10 pm

Thanks for the information. We will post back when we have an update on our investigations.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Pico 6 cannot detect Picoscope 2000

Postby ItronLb » Thu Jun 07, 2012 9:26 am

up...
ItronLb
Newbie
 
Posts: 0
Joined: Mon Feb 13, 2012 8:38 am

Re: Pico 6 cannot detect Picoscope 2000

Postby Hitesh » Thu Jun 07, 2012 10:57 am

Hi,

Please go to Control Panel -> Administrative Tools -> Services and look for the Windows Management Instrumentation. Ensure that the service is running and then try connecting the scope and running PicoScope.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Pico 6 cannot detect Picoscope 2000

Postby Hitesh » Tue Jun 19, 2012 9:09 am

Hi,

Please try downloading and installing PicoScope 6.6.37 (RC) from our website:

http://www.picotech.com/software.html

In Step 1, select your device. In Step 2, select the 'PicoScope 6.6.37 (RC)...' option and then click the 'Download R6.6.37' button when it appears.

Hope this helps,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Pico 6 cannot detect Picoscope 2000

Postby ItronLb » Fri Jun 29, 2012 8:22 am

It's works!
Thanks you
ItronLb
Newbie
 
Posts: 0
Joined: Mon Feb 13, 2012 8:38 am

Re: Pico 6 cannot detect Picoscope 2000

Postby Hitesh » Fri Jun 29, 2012 2:15 pm

Hi ItronLb,

Thanks for letting us know.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Pico 6 cannot detect Picoscope 2000

Postby ccluff » Wed Dec 18, 2013 5:48 pm

I also am having trouble getting the Picoscope 6 software (6.6.57.20) to recognize my device (2208). On a 32 bit WinXP (SP3) machine I am unable to get the USB drivers to install properly. On a 32 bit Vista (SP2) machine it installs, device manager recognizes the device as "PicoScope 2000 series PC Oscilloscope", but Picoscope 6 says "No suitable device found."

I just purchased this device and would like to start using it ASAP. - Thanks Cal
ccluff
Newbie
 
Posts: 0
Joined: Tue Dec 17, 2013 10:58 pm

Re: Pico 6 cannot detect Picoscope 2000

Postby Martyn » Wed Dec 18, 2013 5:58 pm

Is this a 2208 or a 2208a ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2280
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Next

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 1 guest