6.6.x Beta an the CPU usage

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
chrisi1909
Newbie
Posts: 0
Joined: Wed Feb 23, 2011 10:09 am

6.6.x Beta an the CPU usage

Post by chrisi1909 » Fri Oct 14, 2011 6:11 pm

Hi,

I tested this on 5 different Computers including one with a Intel I7-2600k.
I tryed Windows XP 32bit, Win7 32 bit, Win7 64bit and Win8 PreView in diffenrent combinations.

Wenn i start 6.6.4 or 6.6.7(Automotive) Beta an use a Demo device and just look
at the startup sample runing over the screen, the CPU has about 50-55% usage only
from Picoscope.

If i do the same thing with the 6.5.80 i only have 5-15%.

That can´t be normal ?!

Greets Chris

Martyn
Site Admin
Site Admin
Posts: 3333
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: 6.6.x Beta an the CPU usage

Post by Martyn » Mon Oct 17, 2011 7:09 am

The demo driver was changed significantly in 6.6, with only a single demo device rather than demo modes for each of our scopes. The change was made to show more fully the functionality of the software rather than highlighting the capabilities of the individual scopes. For this reason the demo device does use more resources and therefore the results you are seeing are as expected.
Martyn
Technical Support Manager

Gustav
Newbie
Posts: 1
Joined: Sat Jan 23, 2010 1:33 pm

Re: 6.6.x Beta an the CPU usage

Post by Gustav » Thu Oct 20, 2011 9:20 am

Good job chrisi1909!

Make sure, that picoscope does not start to eat PC power, again.


Reducing CPU usage has been one of the great improvements in the latest releases.

Keep the focus on it.

chrisi1909
Newbie
Posts: 0
Joined: Wed Feb 23, 2011 10:09 am

Re: 6.6.x Beta an the CPU usage

Post by chrisi1909 » Fri Oct 21, 2011 10:47 am

I just wondered why that is so much.
If it was an old Pentium 3 oder 4 CPU, or a little Netbook CPU
i would say "O.k, i have to use a bigger CPU", but sorry, the I7-2600K
is under the Top 5 of the now selled Power CPUs...not even CAD-Programms
need ~50% of that CPU and that is doing things where i could accept that.
But its just a Demo View....there is not even 1 Bit transfered via USB.
If there were 10% for the Programm and 15% pllus when its connected and transfering
i would not think about it....

I´m no programmer, but i found it strange, that it jumped so much
with the step vom 6.5.x to 6.6.x.

Pico is doing a great job, and the Soft gets better and better,but
i think i´ll stay with the 6.5 if that usage stays "normal".

Greets Chris

Martyn
Site Admin
Site Admin
Posts: 3333
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: 6.6.x Beta an the CPU usage

Post by Martyn » Fri Oct 21, 2011 11:39 am

With a real device connected it is down around 20% on my standard desktop PC during normal activity.

It is only when running the demo device that it jumps up to 50% as the driver simulates a fully functioning scope to show the majority of features in the software. For example on launch the demo will start a separate signal generator for each of the four channels. Just disabling these will reduce the loading significantly, as does playing around with some of the scope settings.

The 6.5 demo scopes showed a limited range of options linked directly to the choice of scope but many of the more advanced features were not available.

Hope this helps.
Martyn
Technical Support Manager

Post Reply