Search found 112 matches

by mario_
Mon Jan 12, 2015 8:55 am
Forum: PicoScope 6 for Linux
Topic: Drivers for BeagleBoneBlack and Raspberry Pi
Replies: 74
Views: 62634

Re: Drivers for BeagleBoneBlack and Raspberry Pi

Hi Jonathan, libps2000a *should work* on Ubuntu14 on any ARM based board as long as the OS support it. However we haven't tested this particular version of OS on the hardware in subject. The problem you will definitely encounter is OpenCV version. Ubuntu14 supplies libopencv-core2.4 while libpicoipp...
by mario_
Thu Dec 18, 2014 3:21 pm
Forum: PicoScope 6 for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 100925

Re: Beta Release of PicoScope for Linux

Hi Boremi,

Thanks for the shell output - it has let me formulate another patch to the drivers. 6.10.1.27 build is now available through temporary debfix repository. See it if works now...


Mario
by mario_
Wed Dec 10, 2014 9:07 am
Forum: PicoScope 6 for Linux
Topic: libps3000a.so segfault
Replies: 17
Views: 11213

Re: libps3000a.so segfault

Hi Tobiasz, PICO_OPEN_OPERATION_IN_PROGRESS is returned only in 2 cases - while opening unit asynchronously, and in case the previous open operation is still pending. I can tell that most of OpenUnit is enclosed in its own try/catch, so any subsequent exception should be caught. The code outside try...
by mario_
Tue Dec 09, 2014 4:33 pm
Forum: PicoScope 6 for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 100925

Re: Beta Release of PicoScope for Linux

Hi pipau, It seems my revelation was premature. I just tried now - and it crashes... crashes 5 times in every 6 attempts. Analysis of stack traces and some google searches say that it may have something to do with... video card drivers, which makes no sense really. Trying older versions of PicoScope...
by mario_
Tue Dec 09, 2014 11:03 am
Forum: PicoScope 6 for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 100925

Re: Beta Release of PicoScope for Linux

Hi pipau, Thanks for the list of version. I have brought my installation of suse12 to your versions and the crash happens. There is workaround for this: Start PicoScope6 without any device plugged in. Choose not to start Demo Device. Plugin your scope. Use File/Open Device to get it running. Mario
by mario_
Mon Dec 08, 2014 4:35 pm
Forum: PicoScope 6 for Linux
Topic: Picoscope doesn't works under Ubuntu after last updates
Replies: 16
Views: 12876

Re: Picoscope doesn't works under Ubuntu after last updates

Thanks Remi for your information regarding this issue. It affects other customers too and to consolidate further investigations - please observe following tread: http://www.picotech.com/support/post43703.html#p43703

Mario
by mario_
Mon Dec 08, 2014 4:31 pm
Forum: PicoScope 6 for Linux
Topic: PicoScope crash when trying to connect device (2205 MSO)
Replies: 1
Views: 2598

Re: PicoScope crash when trying to connect device (2205 MSO)

Hi ojaybee,

This is affecting quite a few of other customers. Further discussion will be handled from here: http://www.picotech.com/support/post43703.html#p43703

Mario
by mario_
Mon Dec 08, 2014 4:29 pm
Forum: PicoScope 6 for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 100925

Re: Beta Release of PicoScope for Linux

Hi All, I have been trying to replicate the issue on many of our lab, test, dev PC & VMs (including few private ones). So far no crash was observed. But we're getting more and more reports from several customers about that. There must be some sort of a common ground on which the application crashes....
by mario_
Mon Dec 01, 2014 8:41 am
Forum: PicoScope 6 for Linux
Topic: libps3000a.so segfault
Replies: 17
Views: 11213

Re: libps3000a.so segfault

Hi Tobiasz,

Terminate is called as certain exception is being thrown and runtime doesn't know what to do with it. Try enclosing ps3000aOpenUnit within try&catch statement to identify what is actually happening.


Mario
by mario_
Mon Nov 24, 2014 9:03 am
Forum: PicoScope 6 for Linux
Topic: Picoscope doesn't works under Ubuntu after last updates
Replies: 16
Views: 12876

Re: Picoscope doesn't works under Ubuntu after last updates

Hi Rémi, As mentioned earlier, without output from `mono PicoScope.GTK.exe` we won't be able to get the starting point in our investigation. Either paste it here or provide trace.xml file (attach here or send to support@picotech.com). This file can be found in following directory: "/home/remi/.local...
by mario_
Fri Nov 14, 2014 8:39 am
Forum: PicoScope 6 for Mac
Topic: Running picoscope 6.10.1 with homebrew-installed mono
Replies: 2
Views: 4624

Re: Running picoscope 6.10.1 with homebrew-installed mono

Hi Vivek, I am assuming that mono installation ended up in a different location than normal mono MRE installer would put itself to (/Library/Frameworks/Mono.framework). In the PicoScope6 installation you may want to edit 'picoscope' script (located under Contents/MacOS) and adjust DYLD_FALBACK_LIBRA...
by mario_
Fri Nov 14, 2014 8:33 am
Forum: PicoScope 6 for Linux
Topic: Picoscope doesn't works under Ubuntu after last updates
Replies: 16
Views: 12876

Re: Picoscope doesn't works under Ubuntu after last updates

Hi Boremi,

Please verify that your user is in pico group (getent group pico) and the contents of udev rule is as follows (cat /etc/udev/rules.d/95-pico.rules ):

Code: Select all

ATTRS{idVendor}=="0ce9", MODE="664", GROUP="pico"

Mario
by mario_
Wed Nov 12, 2014 9:05 am
Forum: PicoScope 6 for Linux
Topic: Picoscope doesn't works under Ubuntu after last updates
Replies: 16
Views: 12876

Re: Picoscope doesn't works under Ubuntu after last updates

Hi Boremi, cd /opt/picoscope/lib && mono PicoScope.GTK.exe Above should produce at least minimal output, than can help us understand what is actually happening. You could also try starting PicoScope without device plugged in and check if Demo mode works. Was this only PicoScope that got upgraded thi...
by mario_
Tue Nov 11, 2014 1:34 pm
Forum: PicoScope 6 for Linux
Topic: libps3000a.so segfault
Replies: 17
Views: 11213

Re: libps3000a.so segfault

Hi Tobiasz, I have managed to track down the issue and fix it. It was affecting all devices, thus I made the new release available on the repository. You application was hitting limit of open files (1024 by default) and then crashing. Problem was in handling libusb structures - it was leaving behind...
by mario_
Fri Nov 07, 2014 8:47 am
Forum: PicoScope 6 for Linux
Topic: Drivers for BeagleBoneBlack and Raspberry Pi
Replies: 74
Views: 62634

Re: Drivers for BeagleBoneBlack and Raspberry Pi

/usr/bin/ld: warning: libopencv_core.so.2.3, needed by //opt/picoscope/lib/libpicoipp.so.1, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning: libopencv_imgproc.so.2.3, needed by //opt/picoscope/lib/libpicoipp.so.1, not found (try using -rpath or -rpath-link) This is due to Jessie ha...