Search found 67 matches

by Gustav
Wed Mar 07, 2012 7:56 pm
Forum: Pre-Sales Advice
Topic: Low noise scope
Replies: 1
Views: 2619

Low noise scope

Hi I have a 5203 scope that I am happy with and I like the picoscope program. I have used it for 3-4 years now. For my current project, I need to measure noise in the 100MHz-200MHz band. The noise floor of the 5203 is a little too high, to be effective in this project. I know that you have developed...
by Gustav
Thu Feb 23, 2012 10:09 am
Forum: PicoScope 6 for Windows
Topic: New feature idea: triggering on serial decoded bytes
Replies: 5
Views: 2403

New feature idea: triggering on serial decoded bytes

Hi Pico tech, This is just a idea to make a great product greater: I guess that there are many like me, how use your serial decoding alot. Typically, data is comming in packets with a header. It would be great if the trigger could work on a set of bytes. Example: You know that each packet start with...
by Gustav
Wed Feb 22, 2012 3:34 pm
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Re: Data logging with excel

I have tried to upload the file, but your forum does not allow .xlsm extension... The macro itself is just your SDK file with the modifications that you have advised. It is in the attachment. If I power cycle the scope after each macro run, then I can run it as many times as a like. The macro finish...
by Gustav
Wed Feb 22, 2012 8:53 am
Forum: PicoScope 6 for Windows
Topic: "Raising" or "Rising" trigger
Replies: 2
Views: 1637

Re: "Raising" or "Rising" trigger

Thanks, I will get used to it.
by Gustav
Tue Feb 21, 2012 11:05 pm
Forum: PicoScope 6 for Windows
Topic: "Raising" or "Rising" trigger
Replies: 2
Views: 1637

"Raising" or "Rising" trigger

This might to some seem like a minor topic, to people how are not perfectionists. They should stop reading here. .

In PS6, why is the trigger condition "Rising" and not "Raising"? Have you made a spelling mistake? Or is it obvious to a native English speaker, that it is "rising"?
by Gustav
Mon Feb 20, 2012 11:06 pm
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Re: Data logging with excel

Hi Hitesh, Thanks for the instructions. Now I have inserted the "Declare Function RunBlock" line that you advised. The problem before, was not that the path in the declaration was wrong, the declaration was missing completely. :oops: The macro can now run, and the data seems to be correct. There are...
by Gustav
Sat Feb 18, 2012 1:52 pm
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Re: Data logging with excel

With the corrections in place the macro editor gives a complie error in line 106:

status = RunBlock(handle, 0, no_of_samples, timebase, 0, 0)

The RunBlock is not defined, it says.

Best Regards,

Ion
by Gustav
Wed Feb 08, 2012 9:34 am
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Re: Data logging with excel

Hi Hitesh,

I am very happy to see your reply. It will take a few more days before I can get back to you with a proper reply and test results. I have another deadline, that I also have to work on.

Best,
by Gustav
Thu Feb 02, 2012 8:53 pm
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Re: Data logging with excel

Hi Hitesh, Thanks for your reply. It is possible to change the timebase to a higher number, when you also remember to change "Dim timebase As Long". That was a little stumbling block. In this way, I can manage to make some battery voltage measurements. It is not nice, because it is not possible to f...
by Gustav
Wed Feb 01, 2012 10:23 am
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Re: Data logging with excel

The streamData macro consistenly makes Excel freeze. Is there somthing that needs to be changed to make this demo work?
by Gustav
Wed Feb 01, 2012 9:56 am
Forum: VB and VBA (Excel, Access)
Topic: Data logging with excel
Replies: 12
Views: 12582

Data logging with excel

Hi I have downloaded the SDK from picotech and started using the example of the GetData macro in excel. The excel sheet works fine (PS5000.xls). The question is how to modify it? The manual that goes with the SDK has a 5 line section on the excel example. (see section 2.12.3). I need to lower the sa...
by Gustav
Thu Nov 24, 2011 10:57 am
Forum: PicoScope 6 for Windows
Topic: PicoScope version: 6.6.13.15
Replies: 1
Views: 1350

PicoScope version: 6.6.13.15

Hi I updated yesterday to version 6.6.13.15. On my pc it is unstable. There are two problems. 1) Then closing the scope (intentionally, through the menues) it sometimes get hung and it takes approx 20 sec to close. As if it is waiting for a time out. When starting it is often necessary to un-plug an...
by Gustav
Tue Nov 08, 2011 9:37 pm
Forum: PicoScope 6 for Windows
Topic: SPI/UART decoding is great, but ...
Replies: 18
Views: 14883

Re: SPI/UART decoding is great, but ...

Hi, It is so long time since I reported the errors, that I have updated SP6 since... and to my delight seen that these errors have been corrected in PicoScope® 6 - PC Oscilloscope software version: 6.6.12.4 Copyright © 1995-2011, Pico Technology Ltd Model: PicoScope 5203 Serial Number: VJY86/42 USB ...
by Gustav
Thu Nov 03, 2011 5:48 pm
Forum: PicoScope 6 for Windows
Topic: SPI/UART decoding is great, but ...
Replies: 18
Views: 14883

Re: SPI/UART decoding is great, but ...

At the moment I work alot with both UART and SPI signals. Using the current BETA version. There are two more things that should be corrected: 1) When there is a lot of data, then it is impossible to stop PS6. I have to take the probe off the test circuit. Otherwise PS6 is too buzy to check that the ...
by Gustav
Thu Oct 27, 2011 4:33 pm
Forum: PicoScope 6 for Windows
Topic: SPI/UART decoding is great, but ...
Replies: 18
Views: 14883

Re: SPI/UART decoding is great, but ...

I have testet with beta 6.6.10.1. The SPI/UART settings are saved correctly with the startup settings. But the default settings for SPI and UART are still reset to (1) LSB first (SPI) and (2) idle low (UART) and 99% of users will need (1) MSB first (SPI) (2) idle high (UART) This is easy to verify t...