Search found 8 matches

by Justiceb
Mon Oct 17, 2016 4:25 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

Hi, I have the function set up, but am having some problems with the inputs. The type and bandwidth settings I am not sure about, I have tried numerical control but I get an error from labview. For bandwidth I'm guessing I need to put the value I want in in hertz? Also, I located the function immedi...
by Justiceb
Fri Oct 07, 2016 5:29 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

Adjusting those settings did give me a more clear signal, but I am still wanting to filter it some more. I am attempting to implement the SetChannel() function as you recommended. So far I have been able to call the function in labview, but I do not understand how to set the parameter types outlined...
by Justiceb
Fri Sep 30, 2016 4:06 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

i will give that a try, thank you!
by Justiceb
Wed Sep 28, 2016 4:21 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

The labview code is reading a signal from a ultrasonic transducer and measuring the peak to peak time difference between the sent and reflected waves to measure distance
by Justiceb
Wed Sep 28, 2016 4:17 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

here are the settings for the oscilloscope software:
Settings9_28.pssettings
Picoscope settings
(3.19 KiB) Downloaded 158 times
here is my labview code:
Ultrasonic Thickness Measurement.vi
Labview code
(808.02 KiB) Downloaded 226 times
by Justiceb
Mon Sep 26, 2016 7:11 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

Upgrading the driver helped the signal considerably, but it still is not as clear in labview as I can get it in the picoscope software. Is it possible to use the bit resolution or low pass filter options from the picoscope software in labview or perhaps tweak values in the driver?
by Justiceb
Wed Sep 14, 2016 6:12 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Re: Issues with using picoscope 6 tools in labview

Thank you, I will look through the manual and if I'm still stuck I will send those to you. One question though, I see that there was an updated SDK released in 2015, I am using an earlier ps6000.dll driver file. I've downloaded the new sdk but cannot find the "lib" subdirectory in my SDK install. Wh...
by Justiceb
Tue Sep 13, 2016 4:25 pm
Forum: LabVIEW
Topic: Issues with using picoscope 6 tools in labview
Replies: 13
Views: 7374

Issues with using picoscope 6 tools in labview

Hi, I am running a program in labview which reads and analyses a signal from a picoscope 6402D. In order for my program to work, there are some preliminary adjustments I need to make to the signal. I am able to condition the signal to what I want it to look like in the picoscope 6 software, but the ...