Search found 558 matches

by Robin
Mon Oct 04, 2010 2:44 pm
Forum: MATLAB
Topic: PS4000 Series - Callback Function Pointer for MATLAB&LABVIEW
Replies: 18
Views: 17000

Re: PS4000 Series - Callback Function Pointer for MATLAB&LAB

Submitted by Oleksiy: Dear Alex, I had similar problem and contacted support. I think the solution using mex file will be more difficult as it need deeper knowledge on linking in Matlab. Perhaps if you ask Matlab support they will help you. It have something to do with dynamic and static linking. I ...
by Robin
Mon Oct 04, 2010 2:43 pm
Forum: MATLAB
Topic: ps4000 Matlab
Replies: 11
Views: 9770

Re: ps4000 Matlab

Submitted by Oleksiy: I have added library and header file from ps4000sdk to the previous set, thus it is functioning set now. Just to summarize: there is set of files to run three units Picoscope 4424 in Matlab environment. It is functioning, however troubles with memory management lead to occasion...
by Robin
Thu Sep 30, 2010 8:24 am
Forum: LabVIEW
Topic: pico 4424 streaming mode
Replies: 4
Views: 2860

Re: pico 4424 streaming mode

Hi Marco This version should work for you. I have tested it in LabVIEW 2010 and saved it for version 9. The problem was that the memory addresses of the arrays returned by PicoScope4000StartStreaming.vi changed when the VI returned. This didn't happen in version 8. Moving the terminals outside of th...
by Robin
Wed Sep 22, 2010 4:26 pm
Forum: LabVIEW
Topic: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.6???
Replies: 17
Views: 9391

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

The conversion time is 2 seconds plus 1 second per active channel:

http://www.picotech.com/thermistor.html

However, you can request values from the driver as frequently as you like. If a new value is not available, the old one will be repeated.
by Robin
Wed Sep 22, 2010 2:35 pm
Forum: LabVIEW
Topic: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.6???
Replies: 17
Views: 9391

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

The dll should be in the SDK. It will also be in your PicoLog folder (C:\program files\pico technology\pico full)

I've posted it here too.

Robin
by Robin
Wed Sep 22, 2010 2:14 pm
Forum: LabVIEW
Topic: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.6???
Replies: 17
Views: 9391

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Hi I opened it and re-saved it in version 8.2. You should be able to open it now. I noticed that you changed your previous post. Regarding the library, make sure that the dll is in the same folder as the llb file. If it still can't find it, double click on the call library function node and select t...
by Robin
Wed Sep 22, 2010 12:01 pm
Forum: LabVIEW
Topic: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.6???
Replies: 17
Views: 9391

Re: TH03 Updated Labview drivers for labview 7.1 8.5.1 or 8.

Hi

All our software can be downloaded from www.picotech.com/software.html

Drivers/examples are included in the siftware development kits (SDKs)

Robin
by Robin
Wed Sep 22, 2010 8:11 am
Forum: LabVIEW
Topic: NEW LabVIEW Drivers and Examples for 4000, 5000 and 6000.
Replies: 18
Views: 12683

Re: NEW LabVIEW Drivers and Examples for 4000, 5000 and 6000

Hi

I'm not sure I understand the question. If you are trying to get the time of (or between) triggers in rapid block mode, unfortunately this is not possible.

Robin
by Robin
Mon Sep 06, 2010 2:57 pm
Forum: LabVIEW
Topic: NEW LabVIEW Drivers and Examples for 4000, 5000 and 6000.
Replies: 18
Views: 12683

NEW LabVIEW Drivers and Examples for 4000, 5000 and 6000.

We have added new LabVIEW drivers and examples to the SDKs for the 4000, 5000 and 6000 series oscilloscopes. These should make development of LabVIEW applications using these products significantly easier. There is now a library of VIs that wrap the driver API functions. The below image shows how si...
by Robin
Mon Sep 06, 2010 1:23 pm
Forum: C and C++
Topic: Hang on data read with some timebases on Picoscope 2204
Replies: 9
Views: 4790

Re: Hang on data read with some timebases on Picoscope 2204

Hi

All scopes use oversample * 'store length' of memory.

However, our 4000, 5000 and 6000 series scopes have significantly more memory (up to 1 GS).

http://www.picotech.com/oscilloscope-sp ... tions.html

Robin
by Robin
Fri Sep 03, 2010 8:16 am
Forum: C and C++
Topic: TC-08, msdos program in C or C++
Replies: 7
Views: 4368

Re: TC-08, msdos program in C or C++

Hi You can't have multiple programs accessing the TC-08 at the same time. Also, remember that the conversion time for the TC-08 is 100 ms plus 100 ms for each enabled channel. So if you have all 8 channels enabled, it will take 900 ms. The C example uses usb_tc08_get_single. For faster sampling, you...
by Robin
Fri Sep 03, 2010 8:05 am
Forum: C and C++
Topic: Problem using PicoScope4224 sample
Replies: 13
Views: 6437

Re: Problem using PicoScope4224 sample

ps4000con.c does use all channels in both block and streaming modes. See SetDefaults()
by Robin
Fri Sep 03, 2010 8:01 am
Forum: C and C++
Topic: Hang on data read with some timebases on Picoscope 2204
Replies: 9
Views: 4790

Re: Hang on data read with some timebases on Picoscope 2204

Hi I have just tried changing the #define BUFFER_SIZE up to 8000 (the 2204 has 8 kS of memory) and it appeared to be working correctly. As the line "timebase: 10 oversample:8" is not being printed, it sounds like ps2000_get_timebase is always returning zero (not that the driver is hanging), indicati...
by Robin
Thu Sep 02, 2010 12:00 pm
Forum: C and C++
Topic: Hang on data read with some timebases on Picoscope 2204
Replies: 9
Views: 4790

Re: Hang on data read with some timebases on Picoscope 2204

Hi

We believe we have found and fixed the problem.

I have attached an updated driver. Please let me know how you get on with this.

Robin
by Robin
Thu Sep 02, 2010 9:23 am
Forum: C and C++
Topic: Hang on data read with some timebases on Picoscope 2204
Replies: 9
Views: 4790

Re: Hang on data read with some timebases on Picoscope 2204

Hi

Sorry, I should have read your post properly!

It does look like there is a bug somewhere causing the device to not auto-trigger. I found that the unit would trigger if I applied a signal. Is this the case for you?

Robin