Search found 9 matches

by Sigge83
Tue Mar 22, 2016 8:08 am
Forum: PicoScope 6 for Windows
Topic: ThresholdDirection Above/Rising issues
Replies: 8
Views: 1879

Re: ThresholdDirection Above/Rising issues

Hello Martyn,
I do not want to seem impatient, but have you had a chance to discuss it with your development team?

Best Regards
Sixten
by Sigge83
Tue Mar 15, 2016 10:13 am
Forum: PicoScope 6 for Windows
Topic: ThresholdDirection Above/Rising issues
Replies: 8
Views: 1879

Re: ThresholdDirection Above/Rising issues

By the way did you also measure on a DC signal? Because I get the same result as you do if measure on a sine wave (or any signal that doesn't have a DC offset i.e. it has a zero crossing). And then the logical operators AND/OR also behaves the way the should.

Kind Regards
Sixten
by Sigge83
Tue Mar 15, 2016 10:10 am
Forum: PicoScope 6 for Windows
Topic: ThresholdDirection Above/Rising issues
Replies: 8
Views: 1879

Re: ThresholdDirection Above/Rising issues

Hi I had not even considered the logic AND/OR statments. And the strange thing with them is that the seem to be working in the opposite way than what they should. Because if I change one of the signals (it does not matter which of them) to trigger above 6.5 volts the oscilloscope triggers even thoug...
by Sigge83
Tue Mar 15, 2016 8:20 am
Forum: PicoScope 6 for Windows
Topic: ThresholdDirection Above/Rising issues
Replies: 8
Views: 1879

Re: ThresholdDirection Above/Rising issues

Ok, but what I want is for the oscilloscope to trigger on a signal that is above a certain value, how do I do it? Because based on what you wrote the Logic trigger would work if channel A & B was measuring the same signal and both had the "above 1 volt" condition, but as you see in the image below, ...
by Sigge83
Mon Mar 14, 2016 10:10 am
Forum: PicoScope 6 for Windows
Topic: ThresholdDirection Above/Rising issues
Replies: 8
Views: 1879

ThresholdDirection Above/Rising issues

Hi I'm currently writing my own application, and I'm noticing that I encounter the same problem when I use the PicoScope 6 software. Which is when I want to use the "Trigger type", i.e. ThresholdDirection, Above instead of Rising the oscilloscope won't trigger. I'm measuring a DC signal with a littl...
by Sigge83
Tue Dec 08, 2015 7:42 am
Forum: .Net Languages (C#, VB.Net, .)
Topic: Time base question (5444B)
Replies: 2
Views: 2192

Re: Time base question (5444B)

Thank you so much Hitesh for clarifying that!
by Sigge83
Thu Dec 03, 2015 6:16 pm
Forum: .Net Languages (C#, VB.Net, .)
Topic: Time base question (5444B)
Replies: 2
Views: 2192

Time base question (5444B)

Hello, I,m having a hard time figuring out how the GetTimebase() works. I have a Picoscope 5444B set to 12 bit resolution and only one channel active. If I choose a timeBase of 500 ns and wan't to capture 2500 samples I would think that it would work and that I would get a sample interval of 2 ns. T...
by Sigge83
Tue Dec 01, 2015 11:37 am
Forum: .Net Languages (C#, VB.Net, .)
Topic: Triggering Issues (5444B)
Replies: 3
Views: 2272

Re: Triggering Issues (5444B)

Thanks for the explanation and for the quick reply! I hope it's okay that I ask one more thing regarding the triggering in streaming mode. Just like I wrote in the previous post I'll setup my triggering like this: Imports.SetSimpleTrigger(handle, 1, Imports.Channel.ChannelA, 10000, Imports.Threshold...
by Sigge83
Tue Dec 01, 2015 10:18 am
Forum: .Net Languages (C#, VB.Net, .)
Topic: Triggering Issues (5444B)
Replies: 3
Views: 2272

Triggering Issues (5444B)

Hello, My code looks like this: Imports.SetSimpleTrigger (handle, 1, Imports.Channel.ChannelA, 1000, Imports.Threshold Direction.Rising, 0, 0); Imports.RunStreaming (handle, 25, Imports.ReportedTimeUnits.MicroSeconds, 0, 4000, 1, 1, Imports.RatioMode.None, (uint) sample count); Imports.GetStreamingL...