Search found 14 matches

by elzaphod
Wed Apr 17, 2019 12:49 pm
Forum: PicoScope 6 for Windows
Topic: Add individual waveform timestamp to exported files
Replies: 6
Views: 3588

Re: Add individual waveform timestamp to exported files

Dear Martyn,

I just came across this post and would like to ask if there is any progress? A second resolution is very fine for me...


Cheers,
Hendrik
by elzaphod
Mon Nov 20, 2017 4:37 am
Forum: C and C++
Topic: Combining several picoscopes
Replies: 5
Views: 2900

Re: Combining several picoscopes

I saw there is a new Linux Driver. Is this new release backward compatible and is the problem solved?
by elzaphod
Sat Sep 16, 2017 4:46 am
Forum: C and C++
Topic: Combining several picoscopes
Replies: 5
Views: 2900

Re: Combining several picoscopes

Hi Hitesh,


thanks for taking care of my problem.

Can you estimate when there might be a fix available? If it is measured in days or in weeks would be fine already. Based on your answer I would implement the workaround or leave it and wait.


Cheers,
Hendrik
by elzaphod
Tue Sep 12, 2017 5:01 pm
Forum: C and C++
Topic: Combining several picoscopes
Replies: 5
Views: 2900

Combining several picoscopes

Dear all, I need to use four picoscopes 6404D in a C++ written program. A lot of development has already happend but using picoscopes 6403 for that because the 6404Ds have been used elsewhere. So far everthing worked fine. Today I got the 6404Ds and I figured out the following. I try to explain by u...
by elzaphod
Sun Feb 05, 2017 6:54 am
Forum: USB PC Oscilloscopes
Topic: Sampling Precision
Replies: 7
Views: 2352

Re: Sampling Precision

It does not make sense if the error in the sampling rate is really 2ppm and not more, and this is the question. Showing you the entire code would not make sense. Actually the pico-settings are set as in the Labview examples which are coming with the SDK. The system is not turned off in consecutive d...
by elzaphod
Thu Feb 02, 2017 4:26 pm
Forum: USB PC Oscilloscopes
Topic: Sampling Precision
Replies: 7
Views: 2352

Re: Sampling Precision

From the block-mode.vi I get an array with 5M entries. To get the time of each entry: # of entry x 0.8 ns. This means the hole waveform is 4 ms long.

The distance between two signals, which happen e.g. at entry number 100 & 300, is calculated: (300 - 100) x 0.8 ns.

Do you mean this?
by elzaphod
Wed Feb 01, 2017 5:28 pm
Forum: USB PC Oscilloscopes
Topic: Sampling Precision
Replies: 7
Views: 2352

Re: Sampling Precision

Well, I'm not using the Picotech Software, but the Labview SDK. The data was taken during the SuperKEKB commissioning a while ago and just recognize this while analyzing the data. To give you an idea: a pico 6404D has been in use and we measured circulating particle bunches in the SuperKEKB collider...
by elzaphod
Mon Jan 30, 2017 3:30 pm
Forum: USB PC Oscilloscopes
Topic: Sampling Precision
Replies: 7
Views: 2352

Sampling Precision

Dear all, I use a Pico 6404D to record 1 million samples in block mode with 0.8 ns sampling rate. Now, the signals in my waveform have a design distance of 9.838 us, but with my Pico I measure a distance of 10.060 us. This means I am off by 222 ns. To explain this, I checked the data sheet and found...
by elzaphod
Thu Mar 17, 2016 5:39 pm
Forum: LabVIEW
Topic: Pico freezes while taking data
Replies: 4
Views: 3370

Re: Pico freezes while taking data

Thanks for your help! But the problem was solved by using the SDK 32-bit beta.
by elzaphod
Wed Mar 16, 2016 10:31 am
Forum: LabVIEW
Topic: Pico freezes while taking data
Replies: 4
Views: 3370

Re: Pico freezes while taking data

Yes, the blue light is on in this state.

The version is 1.4.4.45

As well when I set the 'Trigger Delay' and 'Auto Trigger TIme' to non-zero events. The error occurs...
by elzaphod
Wed Mar 02, 2016 10:03 am
Forum: LabVIEW
Topic: Pico freezes while taking data
Replies: 4
Views: 3370

Re: Pico freezes while taking data

Supplement:

Basically it means - in my opinion - that the trigger is not firing. I set the 'auto trigger time' and 'trigger delay' both to zero.
by elzaphod
Tue Mar 01, 2016 4:56 pm
Forum: LabVIEW
Topic: Pico freezes while taking data
Replies: 4
Views: 3370

Pico freezes while taking data

Dear all, since a few days the picoscope (6404D & 6403C, happened with both of them) freezes while taking data. I load the pico and trigger settings and go then into a for loop (n = ~[1k, 20m]) where I take data (~400 samples, 800ps timebase, 1 channel) with the block mode. So far I could figure out...
by elzaphod
Wed Feb 03, 2016 9:54 am
Forum: LabVIEW
Topic: Issue with Picoscope 6404D on labview2015
Replies: 3
Views: 3384

Re: Issue with Picoscope 6404D on labview2015

Thank you for your help. Is it possible or are there known issues for using LabView 64-bit and the pico SDK 32-bit on a 64-bit Windows? Since Labview 32-bit on a 64-bit machine only can use 4 GB of internal memory it would be a nice feature... For more information about the memory: http://digital.ni...
by elzaphod
Tue Sep 15, 2015 11:38 am
Forum: LabVIEW
Topic: Issue with Picoscope 6404D on labview2015
Replies: 3
Views: 3384

Issue with Picoscope 6404D on labview2015

Hello guys, I just installed the new labview 2015 on our brand new windows 7 lab computer (64-bit). Unfortunately I am not able to run my old pico-.vi's and not even the picoscope examples. On the old lab pc (win7, 64-bit, but labview 2009 (32-bit) ) everything works fine. I tried the PicoSDK 10.6.1...