Search found 5 matches

by IgorLopez
Thu Aug 27, 2015 5:03 pm
Forum: PicoScope for Linux
Topic: "Got a SIGSEGV while executing native code" Ubuntu 14.04LTS
Replies: 3
Views: 3649

Re: "Got a SIGSEGV while executing native code" Ubuntu 14.04

In the same situation as bernd but with the latest SW: 6.11.6.33 Model: PicoScope 2204A Serial Number: CV682/224 USB Version: 20,0 Calibration Date: den 19 maj 2015 Hardware Version: 17 Driver Version: PS2000 Linux Driver, 2.1.5.6 Also a constant stream of: GLib-CRITICAL **: Source ID xxxxxx was not...
by IgorLopez
Mon Jul 27, 2015 5:03 pm
Forum: General Software Discussions
Topic: Triggering during fast streaming mode does not work
Replies: 3
Views: 3290

Re: Triggering during fast streaming mode does not work

Hi Hitesh, I have already set the delay to 0 and auto_trigger_ms to 0 like this: ok = ps2000_set_trigger(unitOpened.handle, PS2000_CHANNEL_B, 500, PS2000_FALLING, 0, 0); ps2000_set_trigger from doc: delay, the delay, as a percentage of the requested number of data points, between the trigger event a...
by IgorLopez
Sun Jul 26, 2015 1:49 pm
Forum: General Software Discussions
Topic: Triggering during fast streaming mode does not work
Replies: 3
Views: 3290

Triggering during fast streaming mode does not work

Hi, I am having a problem with triggering of a session running in fast streaming mode. The app is set up to capture both channels on my PicoScope 2204A where I would like the capturing to start as soon I get the first falling edge on channel B and then should it capture for 50 ms, e.g. 100000 sample...
by IgorLopez
Sun Jul 26, 2015 6:54 am
Forum: General Software Discussions
Topic: ps2000_open_unit() fails
Replies: 2
Views: 3321

Re: ps2000_open_unit() fails

It was a very easy problem. Since I can run the provided picoscope application I thought my PC was properly setup but when checking with usbtest I get this: Pico USB device found: /dev/bus/usb/002/012 - It belongs to root (which is not you) who has permissions rw- - The members of group pico (which ...
by IgorLopez
Sat Jul 25, 2015 4:38 pm
Forum: General Software Discussions
Topic: ps2000_open_unit() fails
Replies: 2
Views: 3321

ps2000_open_unit() fails

Hi, I am writing a very simple application to capture I2C signals and check why my I2C client does not ACK when Master addresses it. The problem is that my application can't even connect to the PicoScope (I have the 2204A version). My PC (Ubuntu 14.04 x86_64) does work with the HW with the provided ...