Search found 4 matches

by LabGuyJohn
Wed Jul 08, 2015 3:08 pm
Forum: VB and VBA (Excel, Access)
Topic: ps2000 set sig gen built in not functioning
Replies: 5
Views: 6169

Re: ps2000 set sig gen built in not functioning

Hi,

I have it connected to an oscilloscope. The SDK states that it returns "0: if successful" and an "Error code: if failed". I made the recommend changes in the Declaration. Still not functioning. I've tested the sig gen using pico6 and it works there.


Thanks
John
by LabGuyJohn
Mon Jul 06, 2015 7:04 pm
Forum: VB and VBA (Excel, Access)
Topic: ps2000 set sig gen built in not functioning
Replies: 5
Views: 6169

Re: ps2000 set sig gen built in not functioning

Hey,

Yes I have tried setting the Initial frequency the same as the final:

Code: Select all

gensig =  ps2000_set_sig_gen_built_in(ps2000_handle,0, 800000, 0, 50000, 50000, 0, 0, 0, 0)
Still returning "1"

Thanks
John
by LabGuyJohn
Mon Jun 29, 2015 9:52 pm
Forum: VB and VBA (Excel, Access)
Topic: ps2000 set sig gen built in not functioning
Replies: 5
Views: 6169

ps2000 set sig gen built in not functioning

Hi all I've searched around looking for a solution to this... to tell the truth I havent a clue what the problem is. I've coppied code that others claim to be functioning and it still returns a "1". According to the SDK a value of "0" means its working. Thanks for any help! Declaration Declare Funct...
by LabGuyJohn
Mon Jun 29, 2015 6:20 pm
Forum: VB and VBA (Excel, Access)
Topic: need help with ps2000_get_times_and_values
Replies: 0
Views: 3107

need help with ps2000_get_times_and_values

Update: I Figured it out! Also I realize this is in the wrong forum... Sorry. The problem was actually in the set channel function. I misread the SDK and had the channel set to disabled instead of enabled. Hi there, Im new to VBA and to the picoscope but have been tasked with developing an interface...