Search found 14 matches

by jleslie48
Thu Sep 29, 2011 9:45 pm
Forum: C and C++
Topic: looking for a simple c/c++ program to make a waveform
Replies: 1
Views: 2084

looking for a simple c/c++ program to make a waveform

Ok, so for example I want to send 3 300us wide pulses(12v) with a gap (0v) of 700us every 10ms. Do you have any c/c++ sample program that can demonstrate that? Ideally the program would read an TXT file that I could specify the specs of the waveform and have the picoscope do that. the text file woul...
by jleslie48
Mon Apr 02, 2007 12:53 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

Mark, Thanks for your input. I had figured out by trial and terror that changing the denominator will significantly improve the ability of streaming tests to collect my samples without dropping any data. This is a very useful tool for environment testing to be able to collect long samples of data at...
by jleslie48
Tue Mar 20, 2007 3:48 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

streamtests is working!!

ok I got a workaround to the missing data, but I don't know why it works.


If I set the denominator to 10, then I don't drop any data for the 5 seconds.

What is the denominator setting for?
by jleslie48
Fri Mar 16, 2007 8:42 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

If you ask me, we strip it out. I don't want any of the GUI stuff. All I want is the data. As you can see in my version of streamingtests.cpp, I just dump the 5,000,000 element array to an ASCII file, (BTW, if you get rid of my goofy graph the sample data file reduces to 90MB. Quite a bit of savings...
by jleslie48
Thu Mar 15, 2007 2:13 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

today I tried to compile and link the program in release mode hoping that maybe the debug mode and its inherent slower operation were causing the loss of data. No such luck. the release version shows the same loss of signal. I also notice that while I am collecting 5 seconds worth of data, the GUI s...
by jleslie48
Wed Mar 14, 2007 2:38 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

OK, here's my latest. I collect with streamingtest 5,000,000 samples. The sampling seems to start just fine: http://jleslie48.com/picoscope/streamingtest_070314_01.jpg note the red acknowledgement of data. But then it seems to drop out: http://jleslie48.com/picoscope/streamingtest_070314_02.jpg But ...
by jleslie48
Tue Mar 13, 2007 2:08 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

ok heres my backup:

http://jleslie48.com/picoscope/PS3000_71.zip

start with the readme file.

hopefully we can move this forward.

Sincerely,

Jonathan
by jleslie48
Mon Mar 12, 2007 8:55 pm
Forum: General Software Discussions
Topic: streamingtests collects some data now, but still has problem
Replies: 9
Views: 7341

streamingtests collects some data now, but still has problem

Ok, I can build and run streamingtests.cpp now under Windows_XP. the final step was replacing the function description to: void __stdcall StreamingGetOverviewBuffersMaxMin ( short **overviewBuffers, short overflow, unsigned long triggeredAt, short triggered, short auto_stop, unsigned long nValues); ...
by jleslie48
Mon Mar 05, 2007 8:26 pm
Forum: PicoScope 5
Topic: Cannot compile streammingTests.cpp for Pico 3000 series
Replies: 7
Views: 7489

ok I re-analiyzed my run and collect_fast_streaming is NOT collecting any data. the data I was looking at is left over from the previous 'B' command. I am hitting the stub though, on the second pass of the 'L' option, why isn't the stub occuring on the first pass? Although the program crashes on the...
by jleslie48
Mon Mar 05, 2007 7:17 pm
Forum: PicoScope 5
Topic: Cannot compile streammingTests.cpp for Pico 3000 series
Replies: 7
Views: 7489

Sarah, I think I'm a litter farther along than you, so I packed up my work to date, hope it helps. heres what I have so far: http://jleslie48.com/picoscope/picoscope_070305.zip if you unpack it, it makes a directory "C:\jon\c\source\..." I was able to get streamingtest to build and run on Visual C++...
by jleslie48
Mon Mar 05, 2007 6:52 pm
Forum: General Software Discussions
Topic: In need of a working C++ program of ps3000
Replies: 1
Views: 2352

please join the discussion over here:

http://www.picotech.com/support/viewtopic.php?t=3296

we're trying to work it out right now.
by jleslie48
Mon Mar 05, 2007 4:19 pm
Forum: PicoScope 5
Topic: Cannot compile streammingTests.cpp for Pico 3000 series
Replies: 7
Views: 7489

the examples file is not complete. there really needs to be much more extensive directions on how to build and run the examples. It took me nearly half a day to realize that the examples require visual C++ 8.0, why this isn't listed as a pre-requisite is beyond my understanding. I'm fighting with th...
by jleslie48
Thu Feb 22, 2007 11:22 pm
Forum: C and C++
Topic: ok how do I build ps3000con.c???
Replies: 1
Views: 4448

ok how do I build ps3000con.c???

heres my session showing the makefile I've tried to use: C:\jon\c\source\PS3000> type ps3000con._i_ # Borland 5.5 ps3000con mode makefile for CONSOLE [Win32] # # To use: "make -f ps3000con._i_" # CCFLAGS = -c -DWIN32 ps3000con.exe: ps3000con.obj ilink32 -Tpe -ap -c c0x32 ps3000con ps3000con,ps3000co...
by jleslie48
Tue Feb 20, 2007 4:54 pm
Forum: C and C++
Topic: I'd like to start with the canned examples but missing stuff
Replies: 1
Views: 4938

I'd like to start with the canned examples but missing stuff

Well I want to try out the program ps2000.c in: C:\Program Files\Pico Technology\Pico Full\Examples\PS2000 but I look at the source and it references,(from ps2000.c): . . . #include "ps2000.rch" . . . which is not there (from command prompt): Volume in drive C has no label. Volume Serial Number is 5...