Search found 9 matches

by jeremy
Thu May 17, 2018 4:09 am
Forum: PicoScope for Mac
Topic: Latest version of Picoscope on Mac UI not responsive
Replies: 6
Views: 3043

Re: Latest version of Picoscope on Mac UI not responsive

I should have added, yes, I have uninstalled and reinstalled multiple versions of mono.
by jeremy
Mon May 14, 2018 10:12 am
Forum: PicoScope for Mac
Topic: Latest version of Picoscope on Mac UI not responsive
Replies: 6
Views: 3043

Re: Latest version of Picoscope on Mac UI not responsive

Hi Hitesh,

All buttons have the same issue. I'm using the picoscope 3406D MSO.
by jeremy
Mon May 14, 2018 8:42 am
Forum: PicoScope for Mac
Topic: Latest version of Picoscope on Mac UI not responsive
Replies: 6
Views: 3043

Re: Latest version of Picoscope on Mac UI not responsive

I am having this problem too with Mono 5.8.1.0 and picoscope 6.12.9.64. While running, the oscilloscope display shows fine, but clicking on buttons does nothing. If I stop the capture, everything works (until I start it again). Same problem with Mono 5.0.1.1.

I'm running macos 10.13.
by jeremy
Thu Nov 26, 2015 11:26 am
Forum: General Software Discussions
Topic: Streaming mode and differentiating between channels
Replies: 3
Views: 3009

Re: Streaming mode and differentiating between channels

Hi Hitesh, I eventually worked this one out, but thank you for replying. As a suggestion, perhaps it could be added to the programming docs that (from the callback function's perspective) all channel samples will be transferred into their respective buffers exactly in tandem? I was worried that I wo...
by jeremy
Tue Nov 24, 2015 1:35 am
Forum: General Software Discussions
Topic: Streaming mode and differentiating between channels
Replies: 3
Views: 3009

Streaming mode and differentiating between channels

Hi, I am successfully able to use streaming mode with a single channel using my 3406D and the ps3000aStreamingReady() callback. I'm trying to add a second channel now, but I can't seem to work out how to differentiate between the samples from each channel. None of the applicable functions seem to re...
by jeremy
Fri Aug 28, 2015 11:19 am
Forum: USB PC Oscilloscopes
Topic: Does the 3406D support "fast streaming" mode?
Replies: 1
Views: 1132

Does the 3406D support "fast streaming" mode?

Hi,

I'm looking at the document "ps3000pg-en-4.pdf", and in all of the sections about fast streaming, it says: "PicoScope 3224, 3424 and 3425 variants only."

Is this true? Will my 3406D MSO not do the fast streaming mode?
by jeremy
Thu Aug 13, 2015 12:54 pm
Forum: General Software Discussions
Topic: Is there any API library documentation available?
Replies: 1
Views: 2490

Is there any API library documentation available?

Hi, I'm currently looking at the API documentation for the PS3000a, which as far as I can tell is just PS3000Acon.c. The Programmer's Guide listed on the website refers to functions that don't exist in the library on Linux. Is there any actual documentation on the functions available in the library?...
by jeremy
Sun Mar 23, 2014 10:54 am
Forum: Pre-Sales Advice
Topic: Picoscope demo mode triggers extremely slowly?
Replies: 4
Views: 2945

Re: Picoscope demo mode triggers extremely slowly?

Hi again Alan, I received your private message, but unfortunately the forum will not allow me to send or reply to private messages so I am replying here. In answer to your questions, I am using OSX Mavericks 10.9.2 with all of the latest software updates on a 1 month old Macbook Pro Retina 13". Othe...
by jeremy
Sun Mar 23, 2014 7:00 am
Forum: Pre-Sales Advice
Topic: Picoscope demo mode triggers extremely slowly?
Replies: 4
Views: 2945

Picoscope demo mode triggers extremely slowly?

Hi, I'm looking at buying a 3400 series picoscope and I have been playing with the demo software under Win8 VMWare in Mac OSX. Unfortunately, the triggering in the software is slow as molasses even with simple edge triggering. If I turn triggering off (set to none), I get a display update rate of pr...