Search found 11 matches

by ceejaytee
Fri Jul 27, 2007 3:43 pm
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

Hi there

Any news on a possible solution to my problem?.

Regards
Chris
by ceejaytee
Sun Jul 01, 2007 1:46 pm
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

Hi Thanks for your reply. I have switched off my Anti-virus and Firewall software plus anything else that does not need to be running but it has had no effect on PicoScope, the strange results whilst using the ADC100 device with a USBPP adapter are still occurring. In addition to using the ADC100 wi...
by ceejaytee
Wed Jun 27, 2007 7:05 pm
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

Hi Thanks for your reply. I have tried PicoScope on my desktop and the laptop computer I mainly use with the following results.. 1, Desktop 1.3GHz/512Mb running XP Home. Picoscope runs fine with both USBPP adapter and the Parallel port. Running your example Delphi program with the modified code the ...
by ceejaytee
Mon Jun 11, 2007 6:46 pm
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

Hi Mark Many thanks for your reply. I have changed the code as you suggested and found that the USBPP adapter is now starting to operate. But, I seem to be limited to a maximum interval length of 2 seconds. If I set the interval length to anything above this then the program seems to freeze. I have ...
by ceejaytee
Sat Jun 02, 2007 4:03 pm
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

Long time no replies. With reference to the original question above........ Having had similar problems with a PS3224 which turned out to be syntax and variable type issues regarding use within Delphi environment. Has anybody out there successfully adapted a Delphi coded progam using a parallel port...
by ceejaytee
Sun Apr 22, 2007 8:18 am
Forum: General Software Discussions
Topic: Which mode?
Replies: 6
Views: 5321

Hi
Just to let you know, the streaming problem appears to be solved. A little trial and error but all works now.

Many thanks Chris......
by ceejaytee
Mon Apr 16, 2007 6:40 pm
Forum: General Software Discussions
Topic: Which mode?
Replies: 6
Views: 5321

Hi Thanks for your comments regarding streaming within Delphi. The latest software and drivers have been installed which has now allowed the Delphi streaming example to function. This example makes use of a windows timer function rather than the 'while' loop suggested by yourselves. I have tried usi...
by ceejaytee
Mon Apr 02, 2007 7:08 pm
Forum: General Software Discussions
Topic: Which mode?
Replies: 6
Views: 5321

Hello Thanks for your post with a suggestion on how to sample relatively slowly i.e. 300 samples over a 180 second period. Firstly the statement ok = ps3000_run_streaming(ps3000_handle, 1600, 3200, TRUE); appears to be incorrect for use with DELPHI 3 or 2006. An error is generated stating 'incompata...
by ceejaytee
Sun Feb 18, 2007 6:24 pm
Forum: General Software Discussions
Topic: Which mode?
Replies: 6
Views: 5321

Which mode?

Hi there! Having just purchased a Picoscope 3224 for use at work I have a question.... What is the best way to sample 300 times both channels over a 180 second period? (1.66Hz) Currently using an ADC100 I just call:- adc100_set_range(OutputRange,CurrentRange); adc100_set_interval(180000000,SampleH,2...
by ceejaytee
Sun Feb 04, 2007 11:23 am
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

Additional info regarding ADC100 USB/Parallel Adapter

Further to my previous post I have discovered that in the Delphi example for the ADC100 during fast mode the code ok := adc100_get_times_and_values (times, valuesa, valuesb, 100) > 0; does not return a boolean true result. Thus the results are not displayed. If you override and code ok:=true; the re...
by ceejaytee
Sat Feb 03, 2007 11:50 am
Forum: General Software Discussions
Topic: ADC100 In fast mode with USB parallel port adapter fitted
Replies: 14
Views: 13237

ADC100 In fast mode with USB parallel port adapter fitted

For the past 2 years I have been using a Delphi program, written by myself, to gather information from a test rig via an ADC100 device and the parallel port. All has been fine until I connected your USB/Parallel Port Adapter. The program has been altered to read from USB-PP1 instead of LPT1 (port 10...