Search found 5 matches

by mdawkins
Thu Nov 06, 2014 3:16 pm
Forum: MATLAB
Topic: Using Picoscope 6404D with 64 bit Matlab
Replies: 3
Views: 2411

Re: Using Picoscope 6404D with 64 bit Matlab

Hi hitesh,

yes, I have that file on my Matlab path already - copied from the x64 folder in the SDk download

mark
by mdawkins
Thu Nov 06, 2014 10:27 am
Forum: MATLAB
Topic: Using Picoscope 6404D with 64 bit Matlab
Replies: 3
Views: 2411

Using Picoscope 6404D with 64 bit Matlab

Hi, I have been using my Picoscope 6404D with Matlab 32 bit successfully for some time, but would now like to use with 64 bit Matlab 2014b. I have installed Windows 7.1 SDK on my PC, and downloaded the SDK for the 6404D from the picoscope website. From this download I have copied the files in the x6...
by mdawkins
Mon Jan 20, 2014 4:44 pm
Forum: MATLAB
Topic: Accessing Picoscope 6404D via Matlab
Replies: 9
Views: 5907

Re: Accessing Picoscope 6404D via Matlab

Hi Hitesh, Sorry, I wan't clear on which calllib line caused the crash: Matlab crashes at the line: [status_open, data.unithandle, data.serial] = calllib('PS6000', 'ps6000OpenUnit', data.unithandle, data.serial) I get the message asking me if I want to "attempt to continue" and if i do so, matlab ex...
by mdawkins
Wed Jan 15, 2014 9:20 pm
Forum: MATLAB
Topic: Accessing Picoscope 6404D via Matlab
Replies: 9
Views: 5907

Re: Accessing Picoscope 6404D via Matlab

Hi Hitesh, Thanks for the reply and the missing header file. I can now use loadlibrary successfully although I do get warnings: Warning: The data type 'FcnPtr' used by function ps6000RunBlock does not exist. > In loadlibrary at 403 In initialExperiments at 3 Warning: The data type 'FcnPtr' used by f...
by mdawkins
Fri Jan 03, 2014 6:15 pm
Forum: MATLAB
Topic: Accessing Picoscope 6404D via Matlab
Replies: 9
Views: 5907

Accessing Picoscope 6404D via Matlab

Hi, I am trying to get started in controlling a 6000 series picoscope from within matlab. I have not used Picoscope devices before so am unfamiliar with the process. From what I can gather so far on these forums and elsewhere, I will require the WIndows SDK 7.1 installed on my PC, and also to downlo...