Search found 112 matches

by mario_
Tue Aug 02, 2016 7:00 am
Forum: PicoScope for Linux
Topic: ubuntu 12.04 dependencies
Replies: 10
Views: 3405

Re: ubuntu 12.04 dependencies

Hi Gianni, If demo mode works, the the software side is more likely to be OK. I run several tests with your scope model and didn't run into any problems. How about going into demo, waiting for it to start, the plugin the device and try open it via File -> Connect device? Did you try the scope on dif...
by mario_
Wed Jul 27, 2016 6:48 am
Forum: PicoScope for Linux
Topic: ubuntu 12.04 dependencies
Replies: 10
Views: 3405

Re: ubuntu 12.04 dependencies

Looking at the stack, it seems that you have some sort of unsupported settings in the signal generator. Does picoscope work ok, when using only demo device? You can then reset default startup settings. Alternatively you could look into your home folder for .local/share and rename or move Pico Techno...
by mario_
Tue Jul 26, 2016 2:10 pm
Forum: PicoScope for Linux
Topic: ubuntu 12.04 dependencies
Replies: 10
Views: 3405

Re: ubuntu 12.04 dependencies

Looks like permission issue? Things to check: * Is you user member of group pico ? Run `groups` command to verify this. * Is device having correct permissions set up? Run /opt/picoscope/share/doc/libps2000a/usbtest script to verify * Is udev config present and active? Check for /etc/udev/rules.d/95-...
by mario_
Tue Jul 26, 2016 10:49 am
Forum: PicoScope for Linux
Topic: ubuntu 12.04 dependencies
Replies: 10
Views: 3405

Re: ubuntu 12.04 dependencies

Hi deepspace,

It has been now resolved here: topic25641.html#p84721

Mario
by mario_
Tue Jul 26, 2016 10:48 am
Forum: PicoScope for Linux
Topic: Mono Problems (still?)
Replies: 7
Views: 3452

Re: Mono Problems (still?)

The problem you are experiencing has been explained and steps for the resolution given in this post: topic25641.html#p84721
by mario_
Tue Jul 26, 2016 10:47 am
Forum: PicoScope for Linux
Topic: Picomono/Picoscope6 on Ubuntu 12.04
Replies: 0
Views: 4872

Picomono/Picoscope6 on Ubuntu 12.04

Recent changes in the way Picoscope 6 for Linux is deployed brought a new requirement: picomono. This is collection of .Net libraries required to run PicoScope on Linux without conflicts from mono provided for particular OS. We had some reports that currently released picomono (2.10.8-1r02) is not i...
by mario_
Thu Jun 23, 2016 6:57 am
Forum: Linux
Topic: 6404D streaming on Ubuntu 16.04LTS
Replies: 4
Views: 4306

Re: 6404D streaming on Ubuntu 16.04LTS

Thanks for the snippet. I can already see that you have used c_int16 for enums, where it should be c_int32. In my examples I use the following argtypes: [c_int16, c_void_p, c_int32, c_uint32, c_uint32, c_int16, c_uint32, c_int32, c_uint32] It may have difference, depending on the byte alignment betw...
by mario_
Wed Jun 22, 2016 12:39 pm
Forum: Linux
Topic: 6404D streaming on Ubuntu 16.04LTS
Replies: 4
Views: 4306

Re: 6404D streaming on Ubuntu 16.04LTS

Hi Adescour, The parts of code responsible for evaluating parameters are exactly the same between Windows and Linux. The only thing that comes to my mind is the difference in declared types and how ctypes handles it between windows/linux - especially int32 vs uint32 or on system level long in win is...
by mario_
Thu Jun 09, 2016 8:27 am
Forum: PicoScope for Linux
Topic: Mono Problems (still?)
Replies: 7
Views: 3452

Re: Mono Problems (still?)

I have just published the fixed version of picomono. To use it run: sudo apt-get upgrade sudo apt-get install picomono Your system software centre/manager should pickup this update automatically and apply it together with other system system updates if allowed. As for the other problem, I was unable...
by mario_
Mon Jun 06, 2016 8:18 am
Forum: PicoScope for Linux
Topic: Mono Problems (still?)
Replies: 7
Views: 3452

Re: Mono Problems (still?)

Hi, Yes, with the latest version of Picoscope 6 for Linux, we provide our own mono installation, via picomono package. This was required to avoid previous problem, where different OS's provide different (sometime experimental) versions of mono. Some of the changes between version caused picoscope to...
by mario_
Tue Apr 26, 2016 7:40 am
Forum: PicoScope for Mac
Topic: Picoscope device not found
Replies: 3
Views: 3756

Re: Picoscope device not found

Hi Jeremie, Do you have antivirus on your systems, that is set to scan USB devices? Recently we have received quite few reports, where cpu goes through the roof as soon as device is plugged in and any attempt of reading from it is made. We have tracked this down to El Capitan OSX with certain antivi...
by mario_
Fri Apr 08, 2016 7:57 am
Forum: PicoScope for Linux
Topic: Error: IsMV Failed
Replies: 11
Views: 4145

Re: Error: IsMV Failed

https://software.opensuse.org/download/package?project=home:tpokorra:mono&package=mono-opt Unfotunately only version for ubuntu12 is 4.0.4, free from this bug. The others are up to date. You could trying using ubuntu12 setup, even if you have different version of this os. There is alternative with m...
by mario_
Tue Apr 05, 2016 12:13 pm
Forum: PicoScope for Linux
Topic: Error: IsMV Failed
Replies: 11
Views: 4145

Re: Error: IsMV Failed

Actually the error is most commonly associated with mono version. Versions 4.2.1 and newer carry piece of the code that breaks Picoscope 6 for Linux. The fix has been supplied to Mac version, Linux version will get it in the next release. In the meantime I can only advise to use older versions of mo...
by mario_
Fri Dec 04, 2015 11:42 am
Forum: PicoScope for Linux
Topic: Latest mono version breaks picoscope
Replies: 6
Views: 3252

Re: Latest mono version breaks picoscope

Hi Jorgen,

Another thing to try in this case is to compile older version yourself and install it under different location. Then change /opt/picoscope/bin/picoscope script to use that version - modify MONOCMD variable acquisition to fixed value with new location in it.


Mario
by mario_
Fri Dec 04, 2015 9:34 am
Forum: PicoScope for Linux
Topic: Latest mono version breaks picoscope
Replies: 6
Views: 3252

Re: Latest mono version breaks picoscope

Hi johe, Thanks for letting us know. This has been already discovered with mono 4.2.1 running on mac os x, identified as affecting only this platform... The workaround implemented and released last week works, but it wasn't included in Linux release. It will have to wait for the next PicoScope relea...