Search found 4 matches

by gmorganVA
Thu May 02, 2013 8:33 pm
Forum: C and C++
Topic: PicoScope 4224 Streaming works 50% of the time
Replies: 5
Views: 4596

Re: PicoScope 4224 Streaming works 50% of the time

I figured I'd give you a little more information about my environment in case it helps narrow the problem. We have the PicoScope attached to a laptop which is running Windows 7 64-bit with Service Pack 1. We tried running my application with a version of PicoScope software that is earlier than 6.6.5...
by gmorganVA
Wed Apr 24, 2013 9:36 pm
Forum: C and C++
Topic: PicoScope 4224 Streaming works 50% of the time
Replies: 5
Views: 4596

Re: PicoScope 4224 Streaming works 50% of the time

I did some additional investigation and discovered the following: The first time I run my customized example program then streaming usually works. I've changed the code so that the memory for the sample buffers are only allocated when the program starts and then reused for each streaming run. They a...
by gmorganVA
Wed Apr 24, 2013 5:21 pm
Forum: C and C++
Topic: PicoScope 4224 Streaming works 50% of the time
Replies: 5
Views: 4596

Re: PicoScope 4224 Streaming works 50% of the time

I did some additional checking and it appears that the first time I try to do streaming after it is successful I get a scope not ready error. After this point I don't get any errors from the API calls related to streaming data but I also don't get any data. I do get a few busy errors from the GetLat...
by gmorganVA
Wed Apr 24, 2013 4:26 pm
Forum: C and C++
Topic: PicoScope 4224 Streaming works 50% of the time
Replies: 5
Views: 4596

PicoScope 4224 Streaming works 50% of the time

Starting with the sample code supplied with the PicoScope SDK I customized the "immediate streaming" and "triggered streaming" for my application. After modification I noticed that just about every other time (50% or maybe a little greater than 50%) that I start streaming I get no data from the scop...