Search found 9 matches

by drnicolas
Sun May 10, 2015 8:50 pm
Forum: PicoScope 6 for Windows
Topic: Problem with CAN-decoding
Replies: 4
Views: 1512

Re: Problem with CAN-decoding

Thank you. I will try tomorrow.

Can I also use 2 of the digital lines for decoding ? And what about baudrates which are not available via the up/down buttons?

In the meantime I had some succeess which means that for a short time I could decode standard frames but not extended frames
by drnicolas
Sun May 10, 2015 11:07 am
Forum: PicoScope 6 for Windows
Topic: Problem with CAN-decoding
Replies: 4
Views: 1512

Problem with CAN-decoding

I am not veriy experienced with my PicoScope. Today I tried to decode a CAN-Bus and was not successful so far. Please see the attached screenshot First, I see a lot of ripple in my measurement. Probe A is connected to CANH and GND, B is to CANL accordingly. In the youtube-video about decoding CAN th...
by drnicolas
Mon Feb 25, 2013 4:14 pm
Forum: PicoScope 6 for Windows
Topic: Requirements to decode SPI
Replies: 6
Views: 3676

Re: Requirements to decode SPI

But, I have also lots of problems with 32-Bits.

Otherwise, I can write any number of bits in the decoding settings - indeed, 8,16,32 are given in the drop-down list. But I can write any number I like.
by drnicolas
Sat Feb 23, 2013 4:39 pm
Forum: PicoScope 6 for Windows
Topic: Requirements to decode SPI
Replies: 6
Views: 3676

Re: Requirements to decode SPI

Okay, here comes a psdata-file.

It comes from a 12-bit SPI (not 16 Bit).

I always get <unknown> instead of useful data.

D5 is the return-channel and therefore has no useful data at the momemnt.

Do you have any tips for me ?
by drnicolas
Wed Feb 20, 2013 3:01 pm
Forum: PicoScope 6 for Windows
Topic: Requirements to decode SPI
Replies: 6
Views: 3676

Re: Requirements to decode SPI

I am a little better now, but not yet satisfied.

I actually don't know, how I managed that at least some of the packets are decoded.

Maybe the small spikes seen in the data are the problem. Can I get rid of them ?
by drnicolas
Sun Feb 17, 2013 6:47 am
Forum: PicoScope 6 for Windows
Topic: Requirements to decode SPI
Replies: 6
Views: 3676

Requirements to decode SPI

I have porblems to decode SPI-data. I have D0,D1,D2 for MISO, SCK and CS. I have automatic triggering on falling edge of D2. Settings are made for 16 Bit. But, I normally see no decoded data (unknown only) My 16-Bits come in 2 Bytes with a short gap between them. WHat can I do to safely decode SPI ?
by drnicolas
Sat Jan 19, 2013 1:29 pm
Forum: PicoScope 6 for Windows
Topic: debug CAN protocol
Replies: 2
Views: 1251

Re: debug CAN protocol

Thank you for your help.
In the meantime it works.
by drnicolas
Tue Dec 25, 2012 3:39 pm
Forum: PicoScope 6 for Windows
Topic: debug CAN protocol
Replies: 2
Views: 1251

debug CAN protocol

I am a newbie with a 2205 MSO. I try to debug a CAN-bus. I have absolutely no idea what I really need to connect. WIth the first try, I connected a probe on Chan A to CAN High and the clamp to GND. Okay ? The probe A then is configured to DC and Auto - correct ? In the serial decoding window then i ...
by drnicolas
Tue Dec 25, 2012 3:22 pm
Forum: PicoScope 6 for Windows
Topic: How to decode CAN protocol (error message)
Replies: 1
Views: 872

How to decode CAN protocol (error message)

I am a Newbie with a 2205 MSO. Now I try to debug a CAN-communication at the moment with no success. I have a probe connected to Chan A and a second probe to Chan B. At the first try the software presented me only Probe A to link to CAN High (no second line for Chan B). I dont know what I have done ...