Search found 6 matches

by royleith
Fri Jan 24, 2014 3:41 pm
Forum: PicoScope for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 64042

Re: Beta Release of Picoscope for Linux

Hi Martyn, As with the older 2000 series the old 3000 series devices will be supported soon. I can report that my 3204 seems to be running just fine. I'm really getting too old to get this excited over software! I just mention one little gotcha in case someone else makes the same silly mistake. I se...
by royleith
Wed Jan 15, 2014 5:34 pm
Forum: PicoScope for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 64042

Re: Beta Release of Picoscope for Linux

mario,

Unfortunately the software does not recognise my 3204. I checked the supported list and found that only the A and B versions are supported.

Is there any chance of the earlier models being supported?

Roy Leith
by royleith
Wed Jan 15, 2014 4:45 pm
Forum: PicoScope for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 64042

Re: Beta Release of Picoscope for Linux

Hi mario_,

And many thanks. That repository fix worked for me, as well.

I just need to resolve the libps2000a messages, now.

Roy Leith
by royleith
Tue Jan 14, 2014 9:31 am
Forum: PicoScope for Linux
Topic: Beta Release of PicoScope for Linux
Replies: 111
Views: 64042

Re: Beta Release of Picoscope for Linux

As an inveterate repository   I ignored most of your installation advice. In Kubuntu I added the repository using Muon package manager and then used Konsole to add the pgp key. (Thanks for that. I was able to add the keys for a couple of other repositories, as well!). picoscope did not appear in Muo...
by royleith
Thu Feb 09, 2012 8:28 am
Forum: USB PC Oscilloscopes
Topic: Picoscope: new Linux driver for 2204 & 2205
Replies: 10
Views: 9099

Re: Picoscope: new Linux driver for 2204 & 2205

by Martyn » Wed Feb 08, 2012 7:15 am Linux gcc options now require that the libraries are at the end of the line not the start. It has caused problems all over the place sudo gcc PS3000con.c -oPS3000con -lps3000 It compiled and PS3000com works a treat! Thank you. I am looking at the streamed output...
by royleith
Tue Feb 07, 2012 9:10 pm
Forum: USB PC Oscilloscopes
Topic: Picoscope: new Linux driver for 2204 & 2205
Replies: 10
Views: 9099

Re: Picoscope: new Linux driver for 2204 & 2205

I've been trying to get the old drivers for the 3204 to work in Kubuntu 11.10. I've got the drivers installed (using alien) and gained access to the USB port. lsusb gives :Bus 001 Device 012: ID 0ce9:1001 pico Technology PicoScope3204 However, sudo gcc -lps3000 PS3000con.c -oPS3000con just gives rea...