Search found 4164 matches

by Martyn
Tue Aug 09, 2022 8:09 am
Forum: Getting Started
Topic: Possibly a newbie mistake involving x10 probes
Replies: 5
Views: 25

Re: Possibly a newbie mistake involving x10 probes

Which software are you using? and have you set the range to Auto?
by Martyn
Fri Aug 05, 2022 12:37 pm
Forum: Pre-Sales Advice
Topic: Problems posting because of blacklist
Replies: 3
Views: 55

Re: Problems posting because of blacklist

Should be fixed now
by Martyn
Fri Aug 05, 2022 5:41 am
Forum: Getting Started
Topic: Common ground between 2 different USB hubs?
Replies: 10
Views: 137

Re: Common ground between 2 different USB hubs?

There are no components in our cables, the only differences to standard USB cables are :- - The ground and shield are connected at the PC end. This has been part of our cable design for many years and was added to overcome deficiencies with some desktop PC's, particularly the front USB ports which c...
by Martyn
Fri Aug 05, 2022 5:29 am
Forum: Pre-Sales Advice
Topic: Problems posting because of blacklist
Replies: 3
Views: 55

Re: Problems posting because of blacklist

We are aware of this issue and are investigating, it is random although seems to be occurring more often. I have found that previewing the post and then selecting submit fixes it for me.
by Martyn
Thu Aug 04, 2022 6:32 am
Forum: Projects
Topic: Wrong ADC values in every other position of the buffer array
Replies: 17
Views: 312

Re: Wrong ADC values in every other position of the buffer array

Not sure if this is a clue but

Code: Select all

13344 is 0x3420
8244 is 0x2034
and with this pattern repeating are you walking through the buffer at 8 bits but reading 16 bits each time.
by Martyn
Thu Aug 04, 2022 5:31 am
Forum: Projects
Topic: Wrong ADC values in every other position of the buffer array
Replies: 17
Views: 312

Re: Wrong ADC values in every other position of the buffer array

This is the correct enumeration for the ps2000a devices, note it is not a straight enum and the order is different to yours. However as you are using None this would be the same anyway. /// /// Various methods of data reduction. /// Note that a single call to setting the buffers (ie. ps200...
by Martyn
Tue Aug 02, 2022 11:48 am
Forum: Getting Started
Topic: Math function Crank()idle Crank(A,60)idle
Replies: 2
Views: 52

Re: Math function Crank()idle Crank(A,60)idle

Can you try

crank(A;60)

this may be an O/S language issue.
by Martyn
Fri Jul 29, 2022 7:17 pm
Forum: Projects
Topic: Wrong ADC values in every other position of the buffer array
Replies: 17
Views: 312

Re: Wrong ADC values in every other position of the buffer array

With the simplified version of code I would suggest using a known DC voltage at half of the chosen range, and then post the values you are getting back so we can see what you are receiving.
by Martyn
Fri Jul 29, 2022 6:27 am
Forum: Projects
Topic: Wrong ADC values in every other position of the buffer array
Replies: 17
Views: 312

Re: Wrong ADC values in every other position of the buffer array

I would suggest simplifying your code as you are not using data aggregation. Firstly change to using one channel, until you get it working, and then switch to using the ps2000aSetDataBuffer call not the dual buffer aggregation call ps2000aSetDataBuffers as you don't need the MinMax buffers. If this ...
by Martyn
Fri Jul 29, 2022 6:18 am
Forum: Getting Started
Topic: signal generator is inactive in picoscope
Replies: 4
Views: 117

Re: signal generator is inactive in picoscope

That is the Spectrum Mode Settings button which is active when in Spectrum Mode. The Sig Gen button is st the right hand end of the tool bar after each of the channels and the digital button.
by Martyn
Thu Jul 28, 2022 5:44 am
Forum: Projects
Topic: Wrong ADC values in every other position of the buffer array
Replies: 17
Views: 312

Re: Wrong ADC values in every other position of the buffer array

In our C# example

https://github.com/picotech/picosdk-c-s ... Console.cs

the GetValues call on line 401 uses a DownSampleRatio of 1, you are using 0.
by Martyn
Thu Jul 28, 2022 5:35 am
Forum: MATLAB
Topic: Error Connecting to Picoscope in Compiled Exe App
Replies: 6
Views: 146

Re: Error Connecting to Picoscope in Compiled Exe App

Sorry for the misunderstanding, I didn't mean uninstall the SDK, just that the warning was suggesting it wasn't there so would need installing. So reinstall it and if the same error comes up it has something to do with where the compiled application is looking for the library files. You can always t...
by Martyn
Wed Jul 27, 2022 8:41 am
Forum: MATLAB
Topic: Error Connecting to Picoscope in Compiled Exe App
Replies: 6
Views: 146

Re: Error Connecting to Picoscope in Compiled Exe App

Code: Select all

Warning: Folder C:\Program Files\Pico Technology\SDK\lib\ not found. Please ensure that the location of the library files are on the MATLAB path.
Would suggest you don't have the SDK installed
by Martyn
Wed Jul 27, 2022 6:02 am
Forum: Projects
Topic: Wrong ADC values in every other position of the buffer array
Replies: 17
Views: 312

Re: Wrong ADC values in every other position of the buffer array

It would be useful to see your code, either post here or send to support@picotech.com

Please note that even though the PicoScope 2206B is an 8 bit scope the values returned to the application are 16 bit.
by Martyn
Tue Jul 26, 2022 12:37 pm
Forum: MATLAB
Topic: Error Connecting to Picoscope in Compiled Exe App
Replies: 6
Views: 146

Re: Error Connecting to Picoscope in Compiled Exe App

In your code, or the instrument driver, do you have any paths as strings? it looks like you may need to change them to use \\ for each occurrence of \

Code: Select all

C:\Program Files

should become

C:\\Program Files
which is why you are getting the warning about Escaped character '\P' is not valid.