Test and Measurement Forum

PicoScope 2204A + LabView 2015

Post your LabVIEW discussions here

PicoScope 2204A + LabView 2015

Postby robert_spitzenpfeil » Fri Dec 09, 2016 9:57 am

We just bough a bunch of the 2204A PC scopes. So far I'm pretty impressed with the scope itself & the application, especially for a device in this price range.

However, it would be really nice for the students taking the LabView class if the supplied examples worked as well. There seem to be issues with the DLLs supplied & the way LabView calls certain initialization functions. The names appear not to match. I tried to fix it manually, but to no avail.

Any clues as to when the SDK examples might work with LabView 2015?

Regards,

Robert
robert_spitzenpfeil
Newbie
 
Posts: 0
Joined: Fri Dec 09, 2016 9:43 am

Re: PicoScope 2204A + LabView 2015

Postby Martyn » Fri Dec 09, 2016 1:22 pm

The examples should work, provided you have downloaded the 32 or 64 bit ones to match your LabVIEW version.

Please make sure that you are using the ps2000 examples and not the ps2000a ones, they are completely different.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2782
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoScope 2204A + LabView 2015

Postby robert_spitzenpfeil » Fri Dec 09, 2016 2:31 pm

64bit SDK installed, trying 64bit version of LabView 2015.

No go.

I managed to get so far as that the relays of the analog front-end are clicking (sometimes), but that's about it.

See the attached screenshots for details.
Attachments
PS2204A_LabView2015_issues.7z
screenshots
(255.63 KiB) Downloaded 64 times
robert_spitzenpfeil
Newbie
 
Posts: 0
Joined: Fri Dec 09, 2016 9:43 am

Re: PicoScope 2204A + LabView 2015

Postby Martyn » Fri Dec 09, 2016 7:06 pm

I can't check the zip files until later, I am using a phone at present.

One thought are you using the blue Pico USB cable supplied with the units, it you are occasionally getting relay clicks it may be a power issue. Have you also tried the PicoScope 6 software to see if that functions correctly.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2782
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoScope 2204A + LabView 2015

Postby robert_spitzenpfeil » Mon Dec 12, 2016 9:56 am

The PicoScope6 application runs without any issues!

It's just the LabView examples that are unwilling to cooperate. I mentioned the relays clicking, as I was step-by-step trying to fix the DLL calls & it seems some of the initialization code did something (at least once).
robert_spitzenpfeil
Newbie
 
Posts: 0
Joined: Fri Dec 09, 2016 9:43 am

Re: PicoScope 2204A + LabView 2015

Postby Hitesh » Tue Dec 13, 2016 2:22 pm

Hi Robert,

The LabVIEW examples were created using a 32-bit version of LabVIEW and so when you try to load them using a 64-bit version of LabVIEW, the reference to the dll is lost. This means that you have to select the 64-bit dll in the Function tab of the Call Library Function dialog, and select the correct function.

You should find that once you select the location of the 64-bit dll when prompted either on loading the example or changing a function call, the path to the dll will be set for other Call Library Function nodes.

You may also wish to refer to this post (see item 9).

If you could please e-mail support@picotech.com indicating which data collection mode you are using, we can provide a set of files for you to use. These will then be made available via a future SDK example update.

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2491
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PicoScope 2204A + LabView 2015

Postby robert_spitzenpfeil » Thu Dec 15, 2016 12:53 pm

Changing the dll & function names doesn't fix the missing vi for the AWG example.

Furthermore, it would be really helpful if the SDK contained per-device folders & take the guesswork out of the question, which examples might work for the device. There is none for the 22xx devices.
robert_spitzenpfeil
Newbie
 
Posts: 0
Joined: Fri Dec 09, 2016 9:43 am

Re: PicoScope 2204A + LabView 2015

Postby robert_spitzenpfeil » Thu Dec 15, 2016 12:56 pm

I'm currently investigating if it is viable to have students actually use this device with LabView. The emphasis is on using it, not debugging.
robert_spitzenpfeil
Newbie
 
Posts: 0
Joined: Fri Dec 09, 2016 9:43 am

Re: PicoScope 2204A + LabView 2015

Postby Hitesh » Fri Dec 16, 2016 11:23 am

Hi Robert,

Could I ask what you are looking to use the PicoScope 2204A for with LabVIEW?

We can provide updated files if you could please e-mail support@picotech.com

Many thanks,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2491
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 1 guest