Mac beta unusable and Win won't work under Fusion

Discussion forum for the new Picoscope Mac software
Post Reply
unfrostedpoptart
Newbie
Posts: 0
Joined: Sun Feb 04, 2018 10:38 pm

Mac beta unusable and Win won't work under Fusion

Post by unfrostedpoptart » Thu Feb 08, 2018 4:51 am

Help!!!

I just bought a 3203D MSO. I have a 2012 15" Retina MacBook Pro running 10.13.4. I installed the new PicoScope beta for Mac and it works. Sort of. When I set up Spectrum Mode with AWG it begins to freeze a lot and becomes unusable. So, I brought up Windows 7 under VMWare Fusion 8.5.8 and installed the latest stable PicoScope. It looks like it works but it won't connect to the 3203. When I plug in the 3203 USB cable, Fusion asks me if I want to connect it to Mac or Windows and I chose Windows. Then I start PicoScope and another Fusion pop-up asks me where I want to connect PicoScope 3000 Series PC Oscilloscope and I again select Windows. But then, PicoScope pops up an error box saying "The device 'PicoScope 3000 Series PC Oscilloscope' was unable to connect to the ideal host controller. There's also a pop-up the quickly disappears saying something about bad USB device.

What's going on? I spent a lot of money on this thing and need to be debugging some hardware right now and not being a beta-tester. When will there be a stable Mac version? What's causing the errors trying to run on a VM? Does PicoScope for Windows work with Wine/Crossover?

Thanks!

David

Hitesh
Site Admin
Site Admin
Posts: 2829
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Mac beta unusable and Win won't work under Fusion

Post by Hitesh » Thu Feb 08, 2018 9:30 am

Hello David,

We are working towards feature parity between the macOS, Linux and Windows versions, with this being available via the next major release.

Could you please e-mail support@picotech.com with screenshots of the errors and we will look to assist further.

Regards,
Hitesh

Technical Support Engineer

Post Reply