Test and Measurement Forum

reset the connection of the Pico

Post your LabVIEW discussions here

reset the connection of the Pico

Postby Adel_Labview » Wed Sep 27, 2017 10:05 am

Hi everyone,

The oscilloscope I'm using is PicoScope (4424), i use it with Labview 2014 , all work fine :).
The Problem:
when my programm crashed or the Pico ist not correctly closed, in this case i try to make the connection again (ps4000OpenUnit function) so i get the error "Pico not found !"
it work sometimes when i plug-out the USB-cable!
My question:
is there any way or function to reset the connection of the Pico?

Any help would be great,

Thanks
Adel
Adel_Labview
Newbie
 
Posts: 1
Joined: Tue Jun 07, 2016 9:57 am

Re: reset the connection of the Pico

Postby Hitesh » Wed Sep 27, 2017 5:04 pm

Hi Adel,

Assuming you only have one PicoScope 4424 connected to a Windows PC, try calling the ps4000CloseUnit() Call Function library node with a handle value of 16384 (you can find a sub-vi to do this in the PicoScope4000.llb file).

You can then return to your example and run it.

Otherwise, you have to disconnect the device and close LabVIEW via the Windows Task Manager.

Hope this helps,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2498
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: reset the connection of the Pico

Postby Adel_Labview » Thu Sep 28, 2017 9:41 am

Hi Hitesh,

closing Pico with handle value of 16384 and open again --> Everything works fine now !!

Thank you
Adel
Adel_Labview
Newbie
 
Posts: 1
Joined: Tue Jun 07, 2016 9:57 am

Re: reset the connection of the Pico

Postby Hitesh » Thu Sep 28, 2017 11:48 am

Hi Adel,

Good to hear that works! :)

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2498
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: reset the connection of the Pico

Postby jw_666 » Thu Sep 28, 2017 3:12 pm

Would the handle be the same for a Picoscope 5442B?
jw_666
Newbie
 
Posts: 0
Joined: Thu Sep 28, 2017 3:08 pm

Re: reset the connection of the Pico

Postby Martyn » Thu Sep 28, 2017 8:29 pm

Yes it will be if only one unit is used.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2787
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: reset the connection of the Pico

Postby jw_666 » Fri Sep 29, 2017 9:15 am

So what if more than on devive is used, say two PS5442B(s)?
jw_666
Newbie
 
Posts: 0
Joined: Thu Sep 28, 2017 3:08 pm

Re: reset the connection of the Pico

Postby Martyn » Fri Sep 29, 2017 12:15 pm

Check the handles returned when you first open the units. They should 16384, 16385, ....
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2787
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: reset the connection of the Pico

Postby jw_666 » Fri Sep 29, 2017 1:22 pm

Thank you for your help.
jw_666
Newbie
 
Posts: 0
Joined: Thu Sep 28, 2017 3:08 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 1 guest