Test and Measurement Forum

AWG can't provide enough current

Having problems ? let us know the details here

AWG can't provide enough current

Postby Noufnouf » Tue May 23, 2017 9:27 pm

Hello,
I need to do some measurement on a LED component, but the picoscope AWG can't provide enough current (about 200mA is needed).
I'm new with electronics, I tried to use an op amp, but It has to be powered symmetricly, with a positive and a negative voltage.
I don't know how to build a robust symmetric power supply that could provide 200mA with no difficulties.
Please some help would be grateful.
Cheers,
Noufnouf
Newbie
 
Posts: 1
Joined: Tue May 23, 2017 9:15 pm

Re: AWG can't provide enough current

Postby Gerry » Fri May 26, 2017 9:09 am

Hi Noufnouf,

As you are learning electronics and using a PicoScope to look at circuits, it might be better to just add an offset to the SigGen output to make it positive going only, build a single ended voltage follower circuit (there is some information on that here: http://www.ti.com/lit/an/sboa059/sboa059.pdf), buy a low cost single ended power supply or battery, and focus on learning the basics before trying to build a power supply. There is some information on interfacing to a signal generator that may be useful here: topic14443.html (in particular protecting the SigGen output).

What PicoScope model do you have?

Regards,

Gerry
Gerry
Technical Specialist
Gerry
PICO STAFF
PICO STAFF
 
Posts: 150
Joined: Mon Aug 11, 2014 11:14 am


Return to Getting Started

Who is online

Users browsing this forum: No registered users and 0 guests